summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/ndiswrapper/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/ndiswrapper/files')
-rw-r--r--net-wireless/ndiswrapper/files/ndiswrapper-1.56-cflags.patch12
-rw-r--r--net-wireless/ndiswrapper/files/ndiswrapper-1.58-3.9.patch32
-rw-r--r--net-wireless/ndiswrapper/files/ndiswrapper-1.59-3.14.patch48
-rw-r--r--net-wireless/ndiswrapper/files/ndiswrapper-1.59-cflags.patch13
4 files changed, 105 insertions, 0 deletions
diff --git a/net-wireless/ndiswrapper/files/ndiswrapper-1.56-cflags.patch b/net-wireless/ndiswrapper/files/ndiswrapper-1.56-cflags.patch
new file mode 100644
index 000000000000..480274e31c7f
--- /dev/null
+++ b/net-wireless/ndiswrapper/files/ndiswrapper-1.56-cflags.patch
@@ -0,0 +1,12 @@
+diff -ur ndiswrapper-1.56.orig/utils/Makefile ndiswrapper-1.56/utils/Makefile
+--- ndiswrapper-1.56.orig/utils/Makefile 2010-02-11 03:09:32.000000000 +0100
++++ ndiswrapper-1.56/utils/Makefile 2010-08-10 01:33:36.199000011 +0200
+@@ -5,7 +5,7 @@
+ DRIVER_DIR ?= ../driver
+
+ CC = gcc
+-CFLAGS = -g -Wall -I$(DRIVER_DIR)
++CFLAGS += -Wall -I$(DRIVER_DIR)
+
+ DISTFILES=Makefile ndiswrapper loadndisdriver.c ndiswrapper-buginfo
+
diff --git a/net-wireless/ndiswrapper/files/ndiswrapper-1.58-3.9.patch b/net-wireless/ndiswrapper/files/ndiswrapper-1.58-3.9.patch
new file mode 100644
index 000000000000..d9b7f3b58085
--- /dev/null
+++ b/net-wireless/ndiswrapper/files/ndiswrapper-1.58-3.9.patch
@@ -0,0 +1,32 @@
+diff --git a/driver/loader.c b/driver/loader.c
+index 406e6ba..6f2113f 100644
+--- a/driver/loader.c
++++ b/driver/loader.c
+@@ -575,7 +575,11 @@ static int load_user_space_driver(struct load_driver *load_driver)
+ } else {
+ printk(KERN_INFO "%s: driver %s (%s) loaded\n",
+ DRIVER_NAME, wrap_driver->name, wrap_driver->version);
++#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 9, 0)
+ add_taint(TAINT_PROPRIETARY_MODULE);
++#else
++ add_taint(TAINT_PROPRIETARY_MODULE, LOCKDEP_STILL_OK);
++#endif
+ EXIT1(return 0);
+ }
+ }
+diff --git a/driver/wrapper.c b/driver/wrapper.c
+index f77c879..4fcbbe8 100644
+--- a/driver/wrapper.c
++++ b/driver/wrapper.c
+@@ -72,7 +72,11 @@ static void module_cleanup(void)
+ static int __init wrapper_init(void)
+ {
+ #ifdef TAINT_OOT_MODULE
++#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 9, 0)
+ add_taint(TAINT_OOT_MODULE);
++#else
++ add_taint(TAINT_OOT_MODULE, LOCKDEP_STILL_OK);
++#endif
+ #endif
+ printk(KERN_INFO "%s version %s loaded (smp=%s, preempt=%s)\n",
+ DRIVER_NAME, DRIVER_VERSION,
diff --git a/net-wireless/ndiswrapper/files/ndiswrapper-1.59-3.14.patch b/net-wireless/ndiswrapper/files/ndiswrapper-1.59-3.14.patch
new file mode 100644
index 000000000000..9a696f8817f1
--- /dev/null
+++ b/net-wireless/ndiswrapper/files/ndiswrapper-1.59-3.14.patch
@@ -0,0 +1,48 @@
+Index: driver/crt.c
+===================================================================
+--- driver/crt.c (revision 3197)
++++ driver/crt.c (working copy)
+@@ -467,7 +467,7 @@
+ noregparm void WIN_FUNC(_win_srand,1)
+ (UINT seed)
+ {
+- net_srandom(seed);
++ prandom_seed(seed);
+ }
+
+ noregparm int WIN_FUNC(rand,0)
+Index: driver/ntoskernel.h
+===================================================================
+--- driver/ntoskernel.h (revision 3197)
++++ driver/ntoskernel.h (working copy)
+@@ -347,7 +347,7 @@
+ #define netdev_notifier_info_to_dev(x) ((struct net_device *)(x))
+ #endif
+
+-#ifdef INIT_COMPLETION
++#if LINUX_VERSION_CODE < KERNEL_VERSION(3,13,0)
+ static inline void reinit_completion(struct completion *x)
+ {
+ INIT_COMPLETION(*x);
+@@ -354,6 +354,10 @@
+ }
+ #endif
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(3,8,0)
++#define prandom_seed(seed) net_srandom(seed)
++#endif
++
+ /* TICK is 100ns */
+ #define TICKSPERSEC 10000000
+ #define TICKSPERMSEC 10000
+@@ -797,9 +801,8 @@
+ #define nt_spin_unlock_irqrestore(lock, flags) \
+ do { \
+ nt_spin_unlock(lock); \
+- preempt_enable_no_resched(); \
++ preempt_enable(); \
+ local_irq_restore(flags); \
+- preempt_check_resched(); \
+ } while (0)
+
+ static inline ULONG SPAN_PAGES(void *ptr, SIZE_T length)
diff --git a/net-wireless/ndiswrapper/files/ndiswrapper-1.59-cflags.patch b/net-wireless/ndiswrapper/files/ndiswrapper-1.59-cflags.patch
new file mode 100644
index 000000000000..25359c7c30c1
--- /dev/null
+++ b/net-wireless/ndiswrapper/files/ndiswrapper-1.59-cflags.patch
@@ -0,0 +1,13 @@
+diff --git a/utils/Makefile b/utils/Makefile
+index 0e763c6..d555dda 100644
+--- a/utils/Makefile
++++ b/utils/Makefile
+@@ -6,7 +6,7 @@ HEADERS = $(DRIVER_DIR)/loader.h $(DRIVER_DIR)/ndiswrapper.h
+
+ CC = gcc
+ HOSTCC = $(CC)
+-CFLAGS = -g -Wall -I$(DRIVER_DIR)
++CFLAGS += -I$(DRIVER_DIR)
+
+ DISTFILES=Makefile ndiswrapper loadndisdriver.c ndiswrapper-buginfo
+