summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2023-04-04 15:54:53 -0400
committerRick Farina <zerochaos@gentoo.org>2023-04-04 15:55:12 -0400
commit09269b4821e5a1d02a8c2c5769ca813499b1e59e (patch)
tree5b333970e8ddf4bcd7d0246d55a4e6e10fbe6117 /net-wireless/soapysdr
parentnet-wireless/soapysdr: add python 3.11 (diff)
downloadgentoo-09269b4821e5a1d02a8c2c5769ca813499b1e59e.tar.gz
gentoo-09269b4821e5a1d02a8c2c5769ca813499b1e59e.tar.bz2
gentoo-09269b4821e5a1d02a8c2c5769ca813499b1e59e.zip
net-wireless/soapysdr: add 0.8.1
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/soapysdr')
-rw-r--r--net-wireless/soapysdr/Manifest1
-rw-r--r--net-wireless/soapysdr/soapysdr-0.8.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/net-wireless/soapysdr/Manifest b/net-wireless/soapysdr/Manifest
index 8736fc69bae5..608bd6bf2e48 100644
--- a/net-wireless/soapysdr/Manifest
+++ b/net-wireless/soapysdr/Manifest
@@ -1 +1,2 @@
DIST soapysdr-0.7.2.tar.gz 124607 BLAKE2B 534480574e2085bddea52141f26e0da8c70157e2c89a0af1236f3d1eb5b996d4ae5231cd209c610fc22d099bd9db665c4c7aea54081eeca2bb293b9eb1fe7c8e SHA512 2454b9b6bf4542f3bce2c6a8e1c886cee9179ca0e13e3c1e22817a05ef671428a3cb8fea69e496c8b62573f360c248508edf3d0871ec5063dfac8211b122d371
+DIST soapysdr-0.8.1.tar.gz 131252 BLAKE2B 4dc97b683063a1bc52717f15b12a2471a338cebc30dccfd58723792119a496f5170b67eeda1ff4dbcd34811948f70b9f0e5df11b5b1738b46839ca7377fe557b SHA512 50c8f1652bf9ca09215f9c4115175427ca7b5338add7591e31ca0e627093c94b73e7cf7f84fa71ff419cc010d3c1263931506c728bbaa00413a7915d56a87787
diff --git a/net-wireless/soapysdr/soapysdr-0.8.1.ebuild b/net-wireless/soapysdr/soapysdr-0.8.1.ebuild
new file mode 100644
index 000000000000..d05998052986
--- /dev/null
+++ b/net-wireless/soapysdr/soapysdr-0.8.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit cmake python-r1
+
+DESCRIPTION="vendor and platform neutral SDR support library"
+HOMEPAGE="https://github.com/pothosware/SoapySDR"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapySDR.git"
+ EGIT_CLONE_TYPE="shallow"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm ~riscv ~x86"
+ SRC_URI="https://github.com/pothosware/SoapySDR/archive/soapy-sdr-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapySDR-soapy-sdr-"${PV}"
+fi
+
+LICENSE="Boost-1.0"
+SLOT="0/${PV}"
+
+IUSE="bladerf hackrf python rtlsdr plutosdr uhd"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig:0 )
+"
+PDEPEND="bladerf? ( net-wireless/soapybladerf )
+ hackrf? ( net-wireless/soapyhackrf )
+ rtlsdr? ( net-wireless/soapyrtlsdr )
+ plutosdr? ( net-wireless/soapyplutosdr )
+ uhd? ( net-wireless/soapyuhd )"
+
+src_configure() {
+ configuration() {
+ mycmakeargs+=(
+ -DENABLE_PYTHON=ON
+ -DBUILD_PYTHON3=ON
+ )
+ }
+
+ if use python; then
+ python_foreach_impl configuration
+ fi
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ if use python; then
+ python_foreach_impl python_optimize
+ fi
+}