summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2019-01-07 23:05:14 -0500
committerRick Farina <zerochaos@gentoo.org>2019-01-07 23:10:26 -0500
commit9b00002cc2d2c199b0c61f385c3198721e9fbb84 (patch)
treec68a4ea9f788732ae61b8cd8dc5ff43edb33d8f9 /net-wireless/soapysdrplay/soapysdrplay-0.2.0.ebuild
parentx11-terms/alacritty: bump to 0.2.5 (diff)
downloadgentoo-9b00002cc2d2c199b0c61f385c3198721e9fbb84.tar.gz
gentoo-9b00002cc2d2c199b0c61f385c3198721e9fbb84.tar.bz2
gentoo-9b00002cc2d2c199b0c61f385c3198721e9fbb84.zip
net-wireless/soapysdrplay: bump
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/soapysdrplay/soapysdrplay-0.2.0.ebuild')
-rw-r--r--net-wireless/soapysdrplay/soapysdrplay-0.2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-wireless/soapysdrplay/soapysdrplay-0.2.0.ebuild b/net-wireless/soapysdrplay/soapysdrplay-0.2.0.ebuild
new file mode 100644
index 000000000000..935b6c269996
--- /dev/null
+++ b/net-wireless/soapysdrplay/soapysdrplay-0.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Soapy SDR plugin for SDRPlay"
+HOMEPAGE="https://github.com/pothosware/SoapySDRPlay"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapySDRPlay.git"
+ EGIT_CLONE_TYPE="shallow"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pothosware/SoapySDRPlay/archive/soapy-sdrplay-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapySDRPlay-soapy-sdrplay-"${PV}"
+fi
+
+LICENSE="Boost-1.0"
+SLOT="0"
+
+IUSE=""
+REQUIRED_USE=""
+
+RDEPEND="net-wireless/soapysdr
+ net-wireless/sdrplay"
+DEPEND="${RDEPEND}"