summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-26 23:12:15 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-27 21:00:21 +0200
commit89cd5c260da910b885f9c760b4e7d8b99ab1553d (patch)
tree029886bc6fb1860daa5c1dd17f11c84ef3b803a3 /net-wireless/ubertooth/ubertooth-9999.ebuild
parentx11-themes/qtcurve: Drop 2/3 unused cmake variables (diff)
downloadgentoo-89cd5c260da910b885f9c760b4e7d8b99ab1553d.tar.gz
gentoo-89cd5c260da910b885f9c760b4e7d8b99ab1553d.tar.bz2
gentoo-89cd5c260da910b885f9c760b4e7d8b99ab1553d.zip
net-wireless/ubertooth: Drop USE=specan, depends on Qt4
Bug: https://bugs.gentoo.org/569948 Bug: https://bugs.gentoo.org/649576 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-wireless/ubertooth/ubertooth-9999.ebuild')
-rw-r--r--net-wireless/ubertooth/ubertooth-9999.ebuild42
1 files changed, 5 insertions, 37 deletions
diff --git a/net-wireless/ubertooth/ubertooth-9999.ebuild b/net-wireless/ubertooth/ubertooth-9999.ebuild
index de2e949b8cb6..1341a9478aa6 100644
--- a/net-wireless/ubertooth/ubertooth-9999.ebuild
+++ b/net-wireless/ubertooth/ubertooth-9999.ebuild
@@ -1,28 +1,21 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_OPTIONAL=1
-
-inherit multilib distutils-r1 cmake-utils udev
+inherit cmake-utils udev
HOMEPAGE="http://ubertooth.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+bluez +specan static-libs +ubertooth1-firmware +udev"
-REQUIRED_USE="specan? ( ${PYTHON_REQUIRED_USE} )"
+IUSE="+bluez static-libs +ubertooth1-firmware +udev"
+
DEPEND="bluez? ( net-wireless/bluez:= )
>=net-libs/libbtbb-${PV}:=[static-libs?]
- specan? ( ${PYTHON_DEPS} )
static-libs? ( dev-libs/libusb[static-libs] )
virtual/libusb:1="
RDEPEND="${DEPEND}
- specan? ( >=dev-qt/qtgui-4.7.2:4
- >=dev-python/pyside-1.0.2[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.3[${PYTHON_USEDEP}] )
udev? ( virtual/udev )"
MY_PV=${PV/\./-}
@@ -42,17 +35,8 @@ DESCRIPTION="open source wireless development platform suitable for Bluetooth ex
#readd firmware building, but do it right
#USE="-fortran -mudflap -nls -openmp -multilib" crossdev --without-headers --genv 'EXTRA_ECONF="--with-mode=thumb --with-cpu=cortex-m3 --with-float=soft"' -s4 -t arm-cortexm3-eabi
-src_prepare() {
- cmake-utils_src_prepare
- if use specan; then
- pushd python/specan_ui || die
- distutils-r1_src_prepare
- popd
- fi
-}
-
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DUSE_BLUEZ=$(usex bluez)
-DBUILD_STATIC_LIB=$(usex static-libs)
-DINSTALL_UDEV_RULES=$(usex udev)
@@ -67,16 +51,6 @@ src_configure() {
cmake-utils_src_configure
}
-src_compile() {
- cmake-utils_src_compile
-
- if use specan; then
- pushd python/specan_ui || die
- distutils-r1_src_compile
- popd
- fi
-}
-
src_install() {
cmake-utils_src_install
@@ -91,12 +65,6 @@ src_install() {
fi
popd
- if use specan; then
- pushd python/specan_ui || die
- distutils-r1_src_install
- popd
- fi
-
elog "Everyone can read from the ubertooth, but to talk to it"
elog "your user needs to be in the usb group."
}