summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2021-02-03 09:56:30 +0000
committerTony Vroon <chainsaw@gentoo.org>2021-02-03 09:56:51 +0000
commit28f7499d2c1da25520b543dbd9716c3ac8d039de (patch)
tree75a7517262646cd4ec23e9f982795ec1ee7dcad7 /net-wireless
parentwww-apps/nextcloud: Removed old (diff)
downloadgentoo-28f7499d2c1da25520b543dbd9716c3ac8d039de.tar.gz
gentoo-28f7499d2c1da25520b543dbd9716c3ac8d039de.tar.bz2
gentoo-28f7499d2c1da25520b543dbd9716c3ac8d039de.zip
net-wireless/wireless-regdb: Version bump to 20201120
With thanks to David Michael, this brings us in line with Fedora. This introduces the following changes compared to 20190603: Egypt (EG) * Channels 12 & 13 are allowable on 2.4GHz range * Outdoor usage of the U-NII-1 & 2A bands is not permitted Great Britain (GB) * Channel 144 on 5GHz range is allowable (5725-5730) * 5.8GHz maximum transmit power is 100mW, not 25mW * DMG band is extended to cover channels 5 & 6 (66-71GHz) Croatia (HR) * Indoor usage & higher transmit power for channels 32-50 on 5GHz * Indoor usage permitted for channels 52-68 Indonesia (ID) * Outdoor usage is not permitted Kazakhstan (KZ) * Channels 12 & 13 are allowable on 2.4GHz range * Higher transmit power for U-NII-1 band * 160MHz channels are permitted on U-NII-2C band * Indoor usage permitted for U-NII-3 band * Channels 1-4 are allowable for WiGig 802.11ad/ay Pakistan (PK) * Channels 144 & 175 are allowable on 5GHz range Russia (RU) * Channels 12 & 13 are allowable on 2.4GHz range * 160MHz channels are permitted on 5GHz * Outdoor usage is not permitted on 5GHz * Channels 1-4 are allowable for WiGig 802.11ad/ay, indoor only Singapore (SG) * U-NII-2C is now available without TPC (harmonised) * Channels 1-4 are allowable for WiGig 802.11ad/ay Taiwan (TW) * Channel 144 is allowable on 5GHz range United States (US) * Channels 12 & 13 are disabled on 2.4GHz due to unclear restrictions * Channels 32, 68 & 144 are allowable on 5GHz range Closes: https://bugs.gentoo.org/766612 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-Off-By: Tony Vroon <chainsaw@gentoo.org> Package-Manager: Portage-3.0.13, Repoman-3.0.2
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/wireless-regdb/Manifest1
-rw-r--r--net-wireless/wireless-regdb/wireless-regdb-20201120.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-wireless/wireless-regdb/Manifest b/net-wireless/wireless-regdb/Manifest
index 98a2e57b34fe..b01cc84beeea 100644
--- a/net-wireless/wireless-regdb/Manifest
+++ b/net-wireless/wireless-regdb/Manifest
@@ -1,2 +1,3 @@
DIST wireless-regdb-2019.03.01.tar.xz 23196 BLAKE2B 804ad05a0270df58dd89eb7193f8b568b5534abfc52b35f519e27cfa1f1922db457c77477b3014bd6b48cdd1bbe9e859a6508afa848cf01efbbf6b20d10c4984 SHA512 f0b94e1f661d86f4fcd39384588e10d7353ad085563ddc40a98446b416ce0d7bd0cbe34f1d9620ac45a33f16b7bfe58419da915061942cd5f51d5a3bf9809d72
DIST wireless-regdb-2019.06.03.tar.xz 23176 BLAKE2B 46ed9c25103a57d2370f07035f27ffd89d6a65cdccb22d283aef524aff60b669f21dd4a4dd78c68229a443640a5fd0faa1ad6917e712181881d4b27ead74f480 SHA512 73209ca28c59d6760349ffb713f550300e80db1592bae52b6d252ac9401fa2bb2ace7e6c30cf55df7541da9cef4c8587f3790f7aa34529552468e4b63a3d8fdb
+DIST wireless-regdb-2020.11.20.tar.xz 24840 BLAKE2B b2db70097db43710cc2b6d8966b5c6d4d910a704a87a0bc979667bfd293d8baa402677b5e5bc0fcc4f49647ede4cd6bc3e17d41288f41e58c5c6cf3b968489a9 SHA512 93764e677c4d5cdcb4e927bff206c646061fe1e65896dd63f683e145d45917545b4e08caa14bfb3ea04ffb85438935503bbde386cbabfef2804905e508ecf7a0
diff --git a/net-wireless/wireless-regdb/wireless-regdb-20201120.ebuild b/net-wireless/wireless-regdb/wireless-regdb-20201120.ebuild
new file mode 100644
index 000000000000..861834a692fc
--- /dev/null
+++ b/net-wireless/wireless-regdb/wireless-regdb-20201120.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="wireless-regdb-${PV:0:4}.${PV:4:2}.${PV:6:2}"
+DESCRIPTION="Binary regulatory database for CRDA"
+HOMEPAGE="https://wireless.kernel.org/en/developers/Regulatory"
+SRC_URI="https://www.kernel.org/pub/software/network/${PN}/${MY_P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ einfo "Recompiling regulatory.bin from db.txt would break CRDA verify. Installing unmodified binary version."
+}
+
+src_install() {
+ # This file is not ABI-specific, and crda itself always hardcodes
+ # this path. So install into a common location for all ABIs to use.
+ insinto /usr/lib/crda
+ doins regulatory.bin
+
+ insinto /etc/wireless-regdb/pubkeys
+ doins sforshee.key.pub.pem
+
+ # Linux 4.15 now complains if the firmware loader
+ # can't find these files #643520
+ insinto /lib/firmware
+ doins regulatory.db
+ doins regulatory.db.p7s
+
+ doman regulatory.bin.5
+ dodoc README db.txt
+}