summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-10 14:02:35 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-10 14:04:14 +0200
commit3e707c4eeaa827412615da898b59111b3db5d7d2 (patch)
tree935819eda6993ad5a5d1a6100895469a2a9aa3ed /net-wireless
parentapp-backup/bareos: drop -Werror; fix build with GCC 12 (diff)
downloadgentoo-3e707c4eeaa827412615da898b59111b3db5d7d2.tar.gz
gentoo-3e707c4eeaa827412615da898b59111b3db5d7d2.tar.bz2
gentoo-3e707c4eeaa827412615da898b59111b3db5d7d2.zip
net-wireless/blueman: Bump to 2.2.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/blueman/Manifest1
-rw-r--r--net-wireless/blueman/blueman-2.2.5.ebuild142
-rw-r--r--net-wireless/blueman/blueman-9999.ebuild35
3 files changed, 165 insertions, 13 deletions
diff --git a/net-wireless/blueman/Manifest b/net-wireless/blueman/Manifest
index dc71bc07a205..eadb14121b05 100644
--- a/net-wireless/blueman/Manifest
+++ b/net-wireless/blueman/Manifest
@@ -1 +1,2 @@
DIST blueman-2.2.3.tar.xz 1587268 BLAKE2B b3a2d275904959437a47eec32b16f9ebd945bf49705d4f4752d9bfa40d7764b73d373225875773491432cf5b72319eba51a7206cccf10dcf6033a98f584a0504 SHA512 ccaf624bdea116c70b375ae62c1b477452207e8df0fa0941b0e80ac9fa9fbf760fa0bd0db1e7dc1e63f6010323c4b0bb228e315a0cb8f6a4283cd9da6cfa012b
+DIST blueman-2.2.5.tar.xz 1575260 BLAKE2B 9e26b3406114b1dd3257bcfd0850bf16385ac3eb2fcd89097e3a0464099b7c64eb4cf1f5cd7630a8387fd258b4b0bf8bc52f01c5da480e543bd11346995392c2 SHA512 265a9286ac943a41f78b587a93e8759ca87b49fcda5a7b34ce520d9e0aee8e6335a1219f46d1c3d9bd3f07be15913b5c4bc101daaa5e9e5b380703733c021a35
diff --git a/net-wireless/blueman/blueman-2.2.5.ebuild b/net-wireless/blueman/blueman-2.2.5.ebuild
new file mode 100644
index 000000000000..14d5a18e335a
--- /dev/null
+++ b/net-wireless/blueman/blueman-2.2.5.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit autotools gnome2-utils linux-info python-single-r1 systemd xdg-utils
+
+DESCRIPTION="Simple and intuitive GTK+ Bluetooth Manager"
+HOMEPAGE="https://github.com/blueman-project/blueman/"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/blueman-project/blueman.git"
+else
+ SRC_URI="
+ https://github.com/blueman-project/blueman/releases/download/${PV/_/.}/${P/_/.}.tar.xz
+ "
+ S=${WORKDIR}/${P/_/.}
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+# icons are GPL-2
+# source files are mixed GPL-3+ and GPL-2+
+LICENSE="GPL-3+ GPL-2"
+SLOT="0"
+IUSE="appindicator network nls policykit pulseaudio"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ >=net-wireless/bluez-5:=
+ ${PYTHON_DEPS}"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ')
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ ')
+ sys-apps/dbus
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ || (
+ x11-themes/adwaita-icon-theme
+ x11-themes/faenza-icon-theme
+ x11-themes/mate-icon-theme
+ )
+ appindicator? (
+ dev-libs/libappindicator:3[introspection]
+ )
+ network? (
+ net-firewall/iptables
+ || (
+ sys-apps/net-tools
+ sys-apps/iproute2
+ )
+ || (
+ net-dns/dnsmasq
+ net-misc/dhcp
+ >=net-misc/networkmanager-0.8
+ )
+ )
+ policykit? (
+ sys-auth/polkit
+ )
+ pulseaudio? (
+ || (
+ media-sound/pulseaudio-daemon[bluetooth]
+ media-video/pipewire[bluetooth]
+ <media-sound/pulseaudio-15.99.1[bluetooth]
+ media-sound/pulseaudio-modules-bt
+ )
+ )
+"
+
+pkg_pretend() {
+ if use network; then
+ local CONFIG_CHECK="
+ ~BRIDGE
+ ~IP_NF_IPTABLES
+ ~IP_NF_NAT
+ ~IP_NF_TARGET_MASQUERADE
+ "
+ check_extra_config
+ fi
+}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --disable-runtime-deps-check
+ --disable-static
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ --with-dhcp-config="/etc/dhcp/dhcpd.conf"
+ $(use_enable appindicator)
+ $(use_enable policykit polkit)
+ $(use_enable nls)
+ $(use_enable pulseaudio)
+ # thunar integration is a single data file with no extra deps
+ # so install it unconditionally
+ --enable-thunar-sendto
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ if use policykit; then
+ # Allow users in plugdev group to modify connections
+ insinto /usr/share/polkit-1/rules.d
+ doins "${FILESDIR}/01-org.blueman.rules"
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}
diff --git a/net-wireless/blueman/blueman-9999.ebuild b/net-wireless/blueman/blueman-9999.ebuild
index 090a7032ac19..14d5a18e335a 100644
--- a/net-wireless/blueman/blueman-9999.ebuild
+++ b/net-wireless/blueman/blueman-9999.ebuild
@@ -1,21 +1,24 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
-PYTHON_COMPAT=( python3_{8..10} )
inherit autotools gnome2-utils linux-info python-single-r1 systemd xdg-utils
DESCRIPTION="Simple and intuitive GTK+ Bluetooth Manager"
-HOMEPAGE="https://github.com/blueman-project/blueman"
+HOMEPAGE="https://github.com/blueman-project/blueman/"
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/blueman-project/blueman.git"
else
- SRC_URI="https://github.com/blueman-project/${PN}/releases/download/${PV/_/.}/${P/_/.}.tar.xz"
+ SRC_URI="
+ https://github.com/blueman-project/blueman/releases/download/${PV/_/.}/${P/_/.}.tar.xz
+ "
S=${WORKDIR}/${P/_/.}
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
fi
# icons are GPL-2
@@ -23,6 +26,7 @@ fi
LICENSE="GPL-3+ GPL-2"
SLOT="0"
IUSE="appindicator network nls policykit pulseaudio"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="
$(python_gen_cond_dep '
@@ -48,7 +52,9 @@ RDEPEND="${DEPEND}
x11-themes/faenza-icon-theme
x11-themes/mate-icon-theme
)
- appindicator? ( dev-libs/libappindicator:3[introspection] )
+ appindicator? (
+ dev-libs/libappindicator:3[introspection]
+ )
network? (
net-firewall/iptables
|| (
@@ -61,7 +67,9 @@ RDEPEND="${DEPEND}
>=net-misc/networkmanager-0.8
)
)
- policykit? ( sys-auth/polkit )
+ policykit? (
+ sys-auth/polkit
+ )
pulseaudio? (
|| (
media-sound/pulseaudio-daemon[bluetooth]
@@ -72,12 +80,14 @@ RDEPEND="${DEPEND}
)
"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
pkg_pretend() {
if use network; then
- local CONFIG_CHECK="~BRIDGE ~IP_NF_IPTABLES
- ~IP_NF_NAT ~IP_NF_TARGET_MASQUERADE"
+ local CONFIG_CHECK="
+ ~BRIDGE
+ ~IP_NF_IPTABLES
+ ~IP_NF_NAT
+ ~IP_NF_TARGET_MASQUERADE
+ "
check_extra_config
fi
}
@@ -88,8 +98,7 @@ pkg_setup() {
src_prepare() {
default
- # replace py-compile to fix py3
- [[ ${PV} == 9999 ]] && eautoreconf || eautomake
+ [[ ${PV} == 9999 ]] && eautoreconf
}
src_configure() {