summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-04-10 16:19:40 -0400
committerRick Farina <zerochaos@gentoo.org>2020-04-10 16:19:54 -0400
commit6bce09ad1f3ac65679428ae402a6c6425ed412c6 (patch)
treeea1080a5be678bcb29ec668458a45f28ae7021a7 /net-wireless
parentnet-misc/remmina: depend on <freerdp-3 (diff)
downloadgentoo-6bce09ad1f3ac65679428ae402a6c6425ed412c6.tar.gz
gentoo-6bce09ad1f3ac65679428ae402a6c6425ed412c6.tar.bz2
gentoo-6bce09ad1f3ac65679428ae402a6c6425ed412c6.zip
net-wireless/uhd: fix a ton of QA issues
Package-Manager: Portage-2.3.98, Repoman-2.3.22 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/uhd/uhd-3.15.0.0-r1.ebuild (renamed from net-wireless/uhd/uhd-3.15.0.0.ebuild)6
1 files changed, 6 insertions, 0 deletions
diff --git a/net-wireless/uhd/uhd-3.15.0.0.ebuild b/net-wireless/uhd/uhd-3.15.0.0-r1.ebuild
index aa3efa300c7f..0bc67971a97c 100644
--- a/net-wireless/uhd/uhd-3.15.0.0.ebuild
+++ b/net-wireless/uhd/uhd-3.15.0.0-r1.ebuild
@@ -67,6 +67,9 @@ src_prepare() {
#this may not be needed in 3.4.3 and above, please verify
sed -i 's#SET(PKG_LIB_DIR ${PKG_DATA_DIR})#SET(PKG_LIB_DIR ${LIBRARY_DIR}/uhd)#g' CMakeLists.txt || die
+
+ #rpath is set for apple and no one else, just remove the conditional
+ sed -i -e '/if(APPLE)/d' -e '/endif(APPLE)/d' CMakeLists.txt || die
}
src_configure() {
@@ -92,11 +95,14 @@ src_configure() {
-DENABLE_N230="$(usex n230)"
-DENABLE_MPMD="$(usex mpmd)"
-DENABLE_OCTOCLOCK="$(usex octoclock)"
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DPKG_DOC_DIR="${EPREFIX}/usr/share/doc/${PF}"
)
cmake-utils_src_configure
}
src_install() {
cmake-utils_src_install
+ python_optimize
use utils && python_fix_shebang "${ED}"/usr/$(get_libdir)/${PN}/utils/
if [ "${PV}" != "9999" ]; then
rm -rf "${ED}/usr/bin/uhd_images_downloader"