summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-04-19 16:00:17 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-04-19 16:00:17 +0100
commit95cd637b195737a6d1144bfcfcdb636bf5f6dd86 (patch)
treed8073f41af3cef0924f5b980a38815a8b4f62e42 /net-wireless
parentnet-mail/mailgraph: drop lexicographical version compare (diff)
downloadgentoo-95cd637b195737a6d1144bfcfcdb636bf5f6dd86.tar.gz
gentoo-95cd637b195737a6d1144bfcfcdb636bf5f6dd86.tar.bz2
gentoo-95cd637b195737a6d1144bfcfcdb636bf5f6dd86.zip
net-wireless/cpyrit-cuda: fix lexicographical version compare
Closes: https://bugs.gentoo.org/705270 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/cpyrit-cuda/cpyrit-cuda-0.5.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/net-wireless/cpyrit-cuda/cpyrit-cuda-0.5.0.ebuild b/net-wireless/cpyrit-cuda/cpyrit-cuda-0.5.0.ebuild
index 3b338589951f..3c8d5c041e81 100644
--- a/net-wireless/cpyrit-cuda/cpyrit-cuda-0.5.0.ebuild
+++ b/net-wireless/cpyrit-cuda/cpyrit-cuda-0.5.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,7 +6,7 @@ EAPI=6
PYTHON_COMPAT=( python2_7 )
DISTUTILS_SINGLE_IMPL=1
-inherit toolchain-funcs distutils-r1
+inherit toolchain-funcs distutils-r1 eapi7-ver
DESCRIPTION="A sub-package that adds CUDA-capability to Pyrit"
HOMEPAGE="https://github.com/JPaulMora/Pyrit"
@@ -26,8 +26,8 @@ PDEPEND="~net-wireless/pyrit-${PV}"
S="${WORKDIR}/Pyrit-${PV}/modules/cpyrit_cuda"
pkg_pretend() {
- if tc-is-gcc && [[ $(gcc-version) > 4.8 ]]; then
- die "gcc 4.9 and up are not supported"
+ if tc-is-gcc && ver_test $(gcc-version) -ge 4.8; then
+ die "gcc 4.8 and up are not supported"
fi
}