summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-27 14:49:46 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-27 14:54:55 +1300
commit2a1b411345ce81e94771ce2653bea591c703ed91 (patch)
tree93c9a612ba4b4dc48b58ea0f56225c42f257ba81 /perl-core/Math-BigInt/Math-BigInt-1.999.801.ebuild
parentapp-shells/bash: upstream fix for crash on invalid popd #600174 (diff)
downloadgentoo-2a1b411345ce81e94771ce2653bea591c703ed91.tar.gz
gentoo-2a1b411345ce81e94771ce2653bea591c703ed91.tar.bz2
gentoo-2a1b411345ce81e94771ce2653bea591c703ed91.zip
perl-core/Math-BigInt: Bump to version 1.999.801 (masked)
Upstream: - All mathematical methods except ->blog() no longer accept `undef` as operands. - Add _lcm function to Math::BigInt::Lib - Remove internal __lcm() - BigInt and BigFloat can now use bgcd() and blcm() as class-methods. - Prefer getting config values via `->config('name')` instead of `->config()->{name}` - Lock tests to their target libraries Package-Manager: portage-2.3.2
Diffstat (limited to 'perl-core/Math-BigInt/Math-BigInt-1.999.801.ebuild')
-rw-r--r--perl-core/Math-BigInt/Math-BigInt-1.999.801.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/perl-core/Math-BigInt/Math-BigInt-1.999.801.ebuild b/perl-core/Math-BigInt/Math-BigInt-1.999.801.ebuild
new file mode 100644
index 000000000000..77e4931fe30e
--- /dev/null
+++ b/perl-core/Math-BigInt/Math-BigInt-1.999.801.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=PJACKLAM
+DIST_VERSION=1.999801
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Arbitrary size floating point math package"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Math-Complex-1.390.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
+
+PDEPEND="
+ >=virtual/perl-Math-BigInt-FastCalc-0.270.0
+ >=virtual/perl-bignum-0.220.0
+ >=virtual/perl-Math-BigRat-0.260.200
+"
+# where does this come from?
+
+src_test() {
+ perl_rm_files t/author-*.t t/03podcov.t t/00sig.t t/02pod.t
+ perl-module_src_test
+}