summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2020-11-24 13:50:11 +0800
committerBenda Xu <heroxbd@gentoo.org>2020-11-24 13:51:48 +0800
commitf7ae36c9547d429f58be24e0416848cd25e8d8bb (patch)
tree8f665dec4bb21f37e37a940070fc5710b3be907d /profiles/features/prefix
parentdev-lang/rust: update doc symlink (diff)
downloadgentoo-f7ae36c9547d429f58be24e0416848cd25e8d8bb.tar.gz
gentoo-f7ae36c9547d429f58be24e0416848cd25e8d8bb.tar.bz2
gentoo-f7ae36c9547d429f58be24e0416848cd25e8d8bb.zip
profiles/f/p/s/kernel-2.6.16+/p.bashrc: libuv compatibility.
libuv is a dependency of cmake. Switch off CLOEXEC related functions that are not introduced until linux-2.6.27. Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'profiles/features/prefix')
-rw-r--r--profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc6
1 files changed, 5 insertions, 1 deletions
diff --git a/profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc b/profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc
index ed5226a858d2..6370f687cad2 100644
--- a/profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc
+++ b/profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc
@@ -3,6 +3,10 @@
if [[ ${CATEGORY}/${PN} == dev-util/cmake && ${EBUILD_PHASE} == configure ]]; then
einfo "Removing utimensat outputs..."
sed -e '/UTIMENSAT=/d' -i "${S}"/Source/kwsys/CMakeLists.txt || die
+elif [[ ${CATEGORY}/${PN} == dev-libs/libuv && ${EBUILD_PHASE} == prepare ]]; then
+ einfo "Removing CLOEXEC related functions..."
+ sed -e 's/defined(__FreeBSD__) || defined(__linux__)/0/' \
+ -i "${S}"/src/unix/process.c || die
elif [[ ${CATEGORY}/${PN} == dev-qt/qtcore && ${EBUILD_PHASE} == configure ]]; then
einfo "Removing pipe2 definitions..."
sed -e '/define.*HAVE_PIPE2/d' -i "${S}"/src/3rdparty/forkfd/forkfd.c || die
@@ -19,7 +23,7 @@ elif [[ ${CATEGORY}/${PN} == sys-apps/util-linux && ${EBUILD_PHASE} == configure
sed -r -e 's/inotify_init1\(.*\)/inotify_init\(\)/' \
-e '/open\(/s/\| *O_CLOEXEC//' \
-e 's/epoll_create1\(EPOLL_CLOEXEC/epoll_create\(1/' \
- -i "${S}"/libmount/src/monitor.c
+ -i "${S}"/libmount/src/monitor.c || die
fi
# Local Variables: