summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJacob Floyd <cognifloyd@gmail.com>2020-12-20 15:46:30 -0600
committerFabian Groffen <grobian@gentoo.org>2020-12-27 10:49:32 +0100
commit74c82761ee2b2145fc03019edb187869f6856a38 (patch)
tree41b9e2f6639e48aa37775d840c31c613ed3fe905 /profiles/prefix
parentsys-libs/libcxxabi: fix prefix bootstrap (diff)
downloadgentoo-74c82761ee2b2145fc03019edb187869f6856a38.tar.gz
gentoo-74c82761ee2b2145fc03019edb187869f6856a38.tar.bz2
gentoo-74c82761ee2b2145fc03019edb187869f6856a38.zip
sys-libs/libcxx: fix prefix bootstrap
When bootstrapping prefix on darwin, libcxx must be installed before llvm is built during stage2 (in EPREFIX/tmp) and during stage3 (in EPREFIX). llvm_pkg_setup, however, identifies the *installed* llvm to set environment variables with the correct path to llvm. Since llvm is not installed, we have to skip that step. But during bootstrap, we don't need those environment vars to be modified anyway because bootstrap-prefix.sh already sets them with the paths to the correct llvm (which is the host's llm during stage2 and the EPREFIX/tmp llvm during stage3). Once stage3 is complete, llvm is installed in EPREFIX, so the system rebuild (with `emerge -e system`) will successfully use llvm_pkg_setup. bootstrap-prefix.sh is no longer controlling the vars at that point, so it is important to allow llvm_pkg_setup to correctly modify the vars. Other required fixes include: - eprefrixify some dylib paths in CMakeLists.txt (dylib is only used on darwin, so this is not an issue when compiling on other platforms). - ensure want_gcc_s is OFF even if use=-libunwind on darwin - keyword with ~x64-macos Bug: https://bugs.gentoo.org/758167 Signed-off-by: Jacob Floyd <cognifloyd@gmail.com> Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'profiles/prefix')
-rw-r--r--profiles/prefix/darwin/macos/package.use.force4
1 files changed, 4 insertions, 0 deletions
diff --git a/profiles/prefix/darwin/macos/package.use.force b/profiles/prefix/darwin/macos/package.use.force
index 4b4798eb7ee5..c1677ba92529 100644
--- a/profiles/prefix/darwin/macos/package.use.force
+++ b/profiles/prefix/darwin/macos/package.use.force
@@ -21,3 +21,7 @@ media-gfx/tachyon threads opengl
# Elias Pipping <pipping@gentoo.org> (2007-11-29)
# won't compile without
media-libs/libsdl opengl
+
+# Jacob Floyd <cognifloyd@gmail.org> (2020-12-20)
+# Make sure we always use libcxxabi on macos prefix
+sys-libs/libcxx libcxxabi