summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 21:27:05 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 21:30:01 +0200
commitf46c6064a4a922edf806b937998a9b35378787dc (patch)
tree7aaceb3da8780954d1532f62ab9654c1ae212433 /ros-meta/executive_smach/executive_smach-2.0.0.ebuild
parentdev-ros/smach_ros: Initial import. Ebuild by me. (diff)
downloadgentoo-f46c6064a4a922edf806b937998a9b35378787dc.tar.gz
gentoo-f46c6064a4a922edf806b937998a9b35378787dc.tar.bz2
gentoo-f46c6064a4a922edf806b937998a9b35378787dc.zip
ros-meta/executive_smach: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'ros-meta/executive_smach/executive_smach-2.0.0.ebuild')
-rw-r--r--ros-meta/executive_smach/executive_smach-2.0.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/ros-meta/executive_smach/executive_smach-2.0.0.ebuild b/ros-meta/executive_smach/executive_smach-2.0.0.ebuild
new file mode 100644
index 000000000000..76573ce479d0
--- /dev/null
+++ b/ros-meta/executive_smach/executive_smach-2.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/executive_smach"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="SMACH library and ROS SMACH integration packages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/smach
+ dev-ros/smach_ros
+ dev-ros/smach_msgs
+"
+DEPEND="${RDEPEND}"