summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-11 10:27:23 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-11 10:45:28 +0200
commit9e8bdb6736ad71e718b3d3af369eb05133ce1de4 (patch)
treeefa4654f3b8b99b8b50b562c5ef55fc8214ab35b /ros-meta/ros_core/ros_core-1.3.0.ebuild
parentros-meta/ros_core: add gennodejs dep (diff)
downloadgentoo-9e8bdb6736ad71e718b3d3af369eb05133ce1de4.tar.gz
gentoo-9e8bdb6736ad71e718b3d3af369eb05133ce1de4.tar.bz2
gentoo-9e8bdb6736ad71e718b3d3af369eb05133ce1de4.zip
ros-meta/ros_core: bump to 1.3.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'ros-meta/ros_core/ros_core-1.3.0.ebuild')
-rw-r--r--ros-meta/ros_core/ros_core-1.3.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/ros-meta/ros_core/ros_core-1.3.0.ebuild b/ros-meta/ros_core/ros_core-1.3.0.ebuild
new file mode 100644
index 000000000000..70ec9672590f
--- /dev/null
+++ b/ros-meta/ros_core/ros_core-1.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage to aggregate the packages required to use core ROS concepts"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-util/catkin
+ dev-ros/cmake_modules
+ ros-meta/common_msgs
+ dev-ros/gencpp
+ dev-ros/geneus
+ dev-ros/genlisp
+ dev-ros/genpy
+ dev-ros/gennodejs
+ dev-ros/genmsg
+ dev-ros/message_generation
+ dev-ros/message_runtime
+ ros-meta/ros
+ ros-meta/ros_comm
+ dev-ros/rosconsole_bridge
+ ros-meta/roscpp_core
+ dev-ros/rosgraph_msgs
+ dev-ros/rospack
+ dev-ros/std_msgs
+ dev-ros/std_srvs
+ ros-meta/ros_tutorials
+ dev-ros/roslisp
+"
+DEPEND="${RDEPEND}"