summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-09 08:26:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-09 09:14:19 +0200
commita3b0bf152803c96888448aeffe6855b9787743be (patch)
treee0e05289aa272dbd4d5c9ff9585467af11f10f37 /ros-meta/ros_core/ros_core-1.3.1.ebuild
parentros-meta/desktop_full: add urdf_tutorials (diff)
downloadgentoo-a3b0bf152803c96888448aeffe6855b9787743be.tar.gz
gentoo-a3b0bf152803c96888448aeffe6855b9787743be.tar.bz2
gentoo-a3b0bf152803c96888448aeffe6855b9787743be.zip
ros-meta/ros_core: bump to 1.3.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'ros-meta/ros_core/ros_core-1.3.1.ebuild')
-rw-r--r--ros-meta/ros_core/ros_core-1.3.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/ros-meta/ros_core/ros_core-1.3.1.ebuild b/ros-meta/ros_core/ros_core-1.3.1.ebuild
new file mode 100644
index 000000000000..aea8dc9115a1
--- /dev/null
+++ b/ros-meta/ros_core/ros_core-1.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage to aggregate the packages required to use core ROS concepts"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-util/catkin
+ dev-ros/cmake_modules
+ ros-meta/common_msgs
+ dev-ros/gencpp
+ dev-ros/geneus
+ dev-ros/genlisp
+ dev-ros/genpy
+ dev-ros/gennodejs
+ dev-ros/genmsg
+ dev-ros/message_generation
+ dev-ros/message_runtime
+ ros-meta/ros
+ ros-meta/ros_comm
+ dev-ros/rosconsole_bridge
+ ros-meta/roscpp_core
+ dev-ros/rosgraph_msgs
+ dev-ros/rospack
+ dev-ros/std_msgs
+ dev-ros/std_srvs
+ ros-meta/ros_tutorials
+ dev-ros/roslisp
+"
+DEPEND="${RDEPEND}"