summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:29:24 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:29:24 +0200
commit8940d407eb3cf90fed142d5cfcdfb28af0bac585 (patch)
treeaa01ced30d76fb1085026c4bb2f249a93a51235e /ros-meta/rqt_common_plugins/rqt_common_plugins-9999.ebuild
parentdev-ros/rqt_web: Initial import. Ebuild by me. (diff)
downloadgentoo-8940d407eb3cf90fed142d5cfcdfb28af0bac585.tar.gz
gentoo-8940d407eb3cf90fed142d5cfcdfb28af0bac585.tar.bz2
gentoo-8940d407eb3cf90fed142d5cfcdfb28af0bac585.zip
ros-meta/rqt_common_plugins: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'ros-meta/rqt_common_plugins/rqt_common_plugins-9999.ebuild')
-rw-r--r--ros-meta/rqt_common_plugins/rqt_common_plugins-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/ros-meta/rqt_common_plugins/rqt_common_plugins-9999.ebuild b/ros-meta/rqt_common_plugins/rqt_common_plugins-9999.ebuild
new file mode 100644
index 000000000000..8095a09795ee
--- /dev/null
+++ b/ros-meta/rqt_common_plugins/rqt_common_plugins-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS backend graphical tools suite that can be used on/off of robot runtime"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rqt_action
+ dev-ros/rqt_bag
+ dev-ros/rqt_bag_plugins
+ dev-ros/rqt_console
+ dev-ros/rqt_dep
+ dev-ros/rqt_graph
+ dev-ros/rqt_image_view
+ dev-ros/rqt_launch
+ dev-ros/rqt_logger_level
+ dev-ros/rqt_msg
+ dev-ros/rqt_plot
+ dev-ros/rqt_publisher
+ dev-ros/rqt_py_common
+ dev-ros/rqt_py_console
+ dev-ros/rqt_reconfigure
+ dev-ros/rqt_service_caller
+ dev-ros/rqt_shell
+ dev-ros/rqt_srv
+ dev-ros/rqt_top
+ dev-ros/rqt_topic
+ dev-ros/rqt_web
+"
+DEPEND="${RDEPEND}"