summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 11:23:09 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 11:44:15 +0200
commit7bf1257b6c0448cc0335257d8eeb126b42f5be2e (patch)
tree2aac81902c689e459dad8589502a5437674d03d4 /ros-meta/vision_opencv/vision_opencv-9999.ebuild
parentros-meta/image_common: Initial import. Ebuild by me. (diff)
downloadgentoo-7bf1257b6c0448cc0335257d8eeb126b42f5be2e.tar.gz
gentoo-7bf1257b6c0448cc0335257d8eeb126b42f5be2e.tar.bz2
gentoo-7bf1257b6c0448cc0335257d8eeb126b42f5be2e.zip
ros-meta/vision_opencv: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'ros-meta/vision_opencv/vision_opencv-9999.ebuild')
-rw-r--r--ros-meta/vision_opencv/vision_opencv-9999.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/ros-meta/vision_opencv/vision_opencv-9999.ebuild b/ros-meta/vision_opencv/vision_opencv-9999.ebuild
new file mode 100644
index 000000000000..faed03b24e6b
--- /dev/null
+++ b/ros-meta/vision_opencv/vision_opencv-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Converts between ROS Image messages and OpenCV images"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/image_geometry
+ dev-ros/opencv_tests
+"
+DEPEND="${RDEPEND}"