summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:11:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:12:09 +0200
commit2a9e25adaa568563c875886468ee6c9e405ba1e1 (patch)
tree318205d889103d141ae3d8e4dc910d2678bad124 /ros-meta
parentdev-ros/rqt_gui_cpp: Initial import. Ebuild by me. (diff)
downloadgentoo-2a9e25adaa568563c875886468ee6c9e405ba1e1.tar.gz
gentoo-2a9e25adaa568563c875886468ee6c9e405ba1e1.tar.bz2
gentoo-2a9e25adaa568563c875886468ee6c9e405ba1e1.zip
ros-meta/qt_gui_core: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'ros-meta')
-rw-r--r--ros-meta/qt_gui_core/Manifest1
-rw-r--r--ros-meta/qt_gui_core/metadata.xml5
-rw-r--r--ros-meta/qt_gui_core/qt_gui_core-0.2.29.ebuild25
-rw-r--r--ros-meta/qt_gui_core/qt_gui_core-9999.ebuild25
4 files changed, 56 insertions, 0 deletions
diff --git a/ros-meta/qt_gui_core/Manifest b/ros-meta/qt_gui_core/Manifest
new file mode 100644
index 000000000000..85ca418d4e93
--- /dev/null
+++ b/ros-meta/qt_gui_core/Manifest
@@ -0,0 +1 @@
+DIST qt_gui_core-0.2.29.tar.gz 85881 SHA256 7c51b4fd7e795e37e3f8a4b691a5e520466105fdddbc85e194c10c608fe7448c SHA512 958526a3bd76070e121d75a82c589894aef980870091cb853802fcb60328b54cbc95ee0c9eececa18e24608808cca2c722c5699b662c2a578f150995171d71db WHIRLPOOL f83328ce59fd9cd8db5a066f1a2a93bde54b28268891b18cf73b31d5584b0dc7f932350a39e729c97be3bc3b6780422dd2538321f29b0acd13d06387e0054975
diff --git a/ros-meta/qt_gui_core/metadata.xml b/ros-meta/qt_gui_core/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/ros-meta/qt_gui_core/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/ros-meta/qt_gui_core/qt_gui_core-0.2.29.ebuild b/ros-meta/qt_gui_core/qt_gui_core-0.2.29.ebuild
new file mode 100644
index 000000000000..34851c9c874d
--- /dev/null
+++ b/ros-meta/qt_gui_core/qt_gui_core-0.2.29.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Integration of the ROS package system and ROS-specific plugins for a Qt-based GUI"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/qt_dotgraph
+ dev-ros/qt_gui
+ dev-ros/qt_gui_app
+ dev-ros/qt_gui_cpp
+ dev-ros/qt_gui_py_common
+"
+DEPEND="${RDEPEND}"
diff --git a/ros-meta/qt_gui_core/qt_gui_core-9999.ebuild b/ros-meta/qt_gui_core/qt_gui_core-9999.ebuild
new file mode 100644
index 000000000000..34851c9c874d
--- /dev/null
+++ b/ros-meta/qt_gui_core/qt_gui_core-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Integration of the ROS package system and ROS-specific plugins for a Qt-based GUI"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/qt_dotgraph
+ dev-ros/qt_gui
+ dev-ros/qt_gui_app
+ dev-ros/qt_gui_cpp
+ dev-ros/qt_gui_py_common
+"
+DEPEND="${RDEPEND}"