summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 17:25:57 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 18:01:51 +0200
commit8d2284cc3c6b8cd14ed7bf404575104a2861497b (patch)
tree8dd408a287d8cd2f446b25e8178b735388b97868 /ros-meta
parentros-meta/desktop_full: Remove old (diff)
downloadgentoo-8d2284cc3c6b8cd14ed7bf404575104a2861497b.tar.gz
gentoo-8d2284cc3c6b8cd14ed7bf404575104a2861497b.tar.bz2
gentoo-8d2284cc3c6b8cd14ed7bf404575104a2861497b.zip
ros-meta/desktop: bump to 1.5.0
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'ros-meta')
-rw-r--r--ros-meta/desktop/Manifest1
-rw-r--r--ros-meta/desktop/desktop-1.5.0.ebuild29
-rw-r--r--ros-meta/desktop/desktop-9999.ebuild5
3 files changed, 33 insertions, 2 deletions
diff --git a/ros-meta/desktop/Manifest b/ros-meta/desktop/Manifest
index e88baaed2022..16076a420e88 100644
--- a/ros-meta/desktop/Manifest
+++ b/ros-meta/desktop/Manifest
@@ -1,2 +1,3 @@
DIST metapackages-1.4.0.tar.gz 1955 BLAKE2B ef6cfd432f8109a39db9e01dab9fc87f2c2da55f5c6890e9feee69e0a955c4f2eeb092ba61911cb700eb0feff7a2659dbd3b65019bfea960f293ee814b411380 SHA512 7694fcb88081c619e6b5aaedb7fbe2cd77f9cee8a45d79848ba354d654aff77467c3d28925b21c52b985b1cb81e36d2cdf84b5b27bfecd8f54b7acb2c92acd71
DIST metapackages-1.4.1.tar.gz 1961 BLAKE2B 9fb450ad10a9d8485314ddbb1acfaec0961fecfc7098a1de314e2dc5abf55f6267bb5e528a107a46b22f37e1afe96b42b0896e5f2513905d85b94aebeb56e425 SHA512 cbfb8d865d95f2759f8f57df2cb81ef7fa3ca21698e11b442a6dbce5cba8ba93f09022fcafd4efa3e2197ee726e082de62f213e009684a62589358a64495f9fd
+DIST metapackages-1.5.0.tar.gz 2024 BLAKE2B f79f813bfe27e840abb53a46528149f0a7942d7362b66771887dd1452090a19a6169a89aadaa2d4d3dc8104f41834c2c77c2fd702e4cc7f42498e946764b6c7a SHA512 373d402aa98dd617abbfed7c2e733601dcc223eb9ce0f6dde15712dc5ad6b1b4e30c70607f8dde191518893839fd4edfce735443d873e750e0002947e2d44091
diff --git a/ros-meta/desktop/desktop-1.5.0.ebuild b/ros-meta/desktop/desktop-1.5.0.ebuild
new file mode 100644
index 000000000000..7d18ab59b224
--- /dev/null
+++ b/ros-meta/desktop/desktop-1.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage for a basic ROS desktop install"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ ros-meta/robot
+ ros-meta/viz
+ dev-ros/angles
+ ros-meta/common_tutorials
+ ros-meta/geometry_tutorials
+ dev-ros/joint_state_publisher_gui
+ ros-meta/ros_tutorials
+ dev-ros/roslint
+ dev-ros/urdf_tutorial
+ ros-meta/visualization_tutorials
+"
+DEPEND="${RDEPEND}"
diff --git a/ros-meta/desktop/desktop-9999.ebuild b/ros-meta/desktop/desktop-9999.ebuild
index 801a5e18074b..7d18ab59b224 100644
--- a/ros-meta/desktop/desktop-9999.ebuild
+++ b/ros-meta/desktop/desktop-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/metapackages"
KEYWORDS="~amd64"
@@ -20,6 +20,7 @@ RDEPEND="
dev-ros/angles
ros-meta/common_tutorials
ros-meta/geometry_tutorials
+ dev-ros/joint_state_publisher_gui
ros-meta/ros_tutorials
dev-ros/roslint
dev-ros/urdf_tutorial