summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 11:17:27 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 11:39:20 +0200
commite5a7ac57e0d8a2cb7a0872d1dcc59a5c19705cf5 (patch)
treea4d247fe77ad79ea50cdee0bf619800b0ceafa83 /ros-meta
parentros-meta: Add category and its metadata.xml file. (diff)
downloadgentoo-e5a7ac57e0d8a2cb7a0872d1dcc59a5c19705cf5.tar.gz
gentoo-e5a7ac57e0d8a2cb7a0872d1dcc59a5c19705cf5.tar.bz2
gentoo-e5a7ac57e0d8a2cb7a0872d1dcc59a5c19705cf5.zip
ros-meta/roscpp_core: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'ros-meta')
-rw-r--r--ros-meta/roscpp_core/Manifest1
-rw-r--r--ros-meta/roscpp_core/metadata.xml5
-rw-r--r--ros-meta/roscpp_core/roscpp_core-0.5.6.ebuild23
-rw-r--r--ros-meta/roscpp_core/roscpp_core-9999.ebuild23
4 files changed, 52 insertions, 0 deletions
diff --git a/ros-meta/roscpp_core/Manifest b/ros-meta/roscpp_core/Manifest
new file mode 100644
index 000000000000..3fcf6e4ce7b2
--- /dev/null
+++ b/ros-meta/roscpp_core/Manifest
@@ -0,0 +1 @@
+DIST roscpp_core-0.5.6.tar.gz 31734 SHA256 0bd27394c18c7c79313ebc4eafecc04f88aa54a9d0872357b7123105444edf3a SHA512 caebca2817721a46c8ce850bc15bdeadb3bf6ad12aeb134b11bdb04da6054eb4056aef8c5194ca4e7fffa3e3f3563faf8e3148eebfba93bc6b5673d5437d977f WHIRLPOOL f977f9b0e10a287c7d201ffd765a4824e61d0b5f85767c7a8e81d96295f97dcbe22a9c2d376f36a329997d0498ce36f830263e4710eaf288b214b6bf894ede84
diff --git a/ros-meta/roscpp_core/metadata.xml b/ros-meta/roscpp_core/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/ros-meta/roscpp_core/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/ros-meta/roscpp_core/roscpp_core-0.5.6.ebuild b/ros-meta/roscpp_core/roscpp_core-0.5.6.ebuild
new file mode 100644
index 000000000000..b993f6319d7d
--- /dev/null
+++ b/ros-meta/roscpp_core/roscpp_core-0.5.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/roscpp_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Underlying data libraries for roscpp messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rostime
+ dev-ros/roscpp_traits
+ dev-ros/roscpp_serialization
+"
+DEPEND="${RDEPEND}"
diff --git a/ros-meta/roscpp_core/roscpp_core-9999.ebuild b/ros-meta/roscpp_core/roscpp_core-9999.ebuild
new file mode 100644
index 000000000000..b993f6319d7d
--- /dev/null
+++ b/ros-meta/roscpp_core/roscpp_core-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/roscpp_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Underlying data libraries for roscpp messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rostime
+ dev-ros/roscpp_traits
+ dev-ros/roscpp_serialization
+"
+DEPEND="${RDEPEND}"