summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-01-22 23:11:43 +0100
committerPacho Ramos <pacho@gentoo.org>2020-01-22 23:11:43 +0100
commit65dd7962592039947d13d0549fc5906150681f83 (patch)
tree402facf7d492ac75611921428221a7bba0f13d43 /sci-astronomy/celestia
parentdev-python/botocore: drop old (diff)
downloadgentoo-65dd7962592039947d13d0549fc5906150681f83.tar.gz
gentoo-65dd7962592039947d13d0549fc5906150681f83.tar.bz2
gentoo-65dd7962592039947d13d0549fc5906150681f83.zip
sci-astronomy/celestia: Fix Exec in .desktop, provide bigger icons too
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-astronomy/celestia')
-rw-r--r--sci-astronomy/celestia/celestia-9999.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sci-astronomy/celestia/celestia-9999.ebuild b/sci-astronomy/celestia/celestia-9999.ebuild
index 781e1cb43a98..fda29bea8547 100644
--- a/sci-astronomy/celestia/celestia-9999.ebuild
+++ b/sci-astronomy/celestia/celestia-9999.ebuild
@@ -88,12 +88,14 @@ src_install() {
for size in 16 22 32 48 ; do
newicon -s ${size} "${S}"/src/celestia/kde/data/hi${size}-app-${PN}.png ${PN}.png
done
+ newicon -s 128 "${S}"/src/celestia/gtk/data/${PN}-logo.png ${PN}.png
+ doicon -s scalable "${S}"/src/celestia/gtk/data/${PN}.svg
use glut && domenu ${PN}.desktop
if use qt5 ; then
sed \
-e "/^Name/s@\$@ (qt5 interface)@" \
- -e "/^Exec/s@${PN}@${PN}-${ui/qt5/qt}@" \
+ -e "/^Exec/s@${PN}@${PN}-qt@" \
${PN}.desktop > "${T}"/${PN}-qt5.desktop || die
domenu "${T}"/${PN}-qt5.desktop
fi