summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-04-04 21:51:13 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-04-05 22:11:08 +0000
commit4325b2368b64fbc00c26fac20614a33a7c6e7689 (patch)
treead43976d5df6e93c4861be4573fcba7f918d7be9 /sci-astronomy/cpl
parentsci-astronomy/casacore: Version bump (diff)
downloadgentoo-4325b2368b64fbc00c26fac20614a33a7c6e7689.tar.gz
gentoo-4325b2368b64fbc00c26fac20614a33a7c6e7689.tar.bz2
gentoo-4325b2368b64fbc00c26fac20614a33a7c6e7689.zip
sci-astronomy/cpl: Version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-astronomy/cpl')
-rw-r--r--sci-astronomy/cpl/Manifest1
-rw-r--r--sci-astronomy/cpl/cpl-7.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/sci-astronomy/cpl/Manifest b/sci-astronomy/cpl/Manifest
index a19b2676a124..98aaacda9b09 100644
--- a/sci-astronomy/cpl/Manifest
+++ b/sci-astronomy/cpl/Manifest
@@ -1,2 +1,3 @@
DIST cpl-6.4.2.tar.gz 3165143 SHA256 848dbbc581670b32eeb3d87a7c3c10c9d3969f0fcbe7daf8ba18ef0081cbc793 SHA512 636ce549f23862a111fd88e97878eff8b86c88e8e2e800533b2f34f219f6b6ea3f03bd9de6ce9606c3787d0a61fb66a6bd92087d24c57c47e5a26e31eb362a11 WHIRLPOOL 7368e323c4f00af8fc684ba1448eec20f229df310b9cd66f0fe046dd6900a195c04fbc1c78dd31600651c8e7911f49517a37ddb4ba89df235fadb5c0e1a0cb81
DIST cpl-6.6.1.tar.gz 3082051 SHA256 16cd1c5a165526423d5dd7999f9080e1fa143fc38778329744cf59fd24e1bb84 SHA512 261cd092b3d0f1865f2e1aca0760232497cfe85b92f61601b22d81619147cad17c427791adad5a863acb3febcfe78590c8f8d10de1d626f4b90302326f936064 WHIRLPOOL ea7c5f7792da54a46eec9f3a8e040c2598b8ec95a9aeccc8451e77aa9773c2ccdf3113e91f2f6f2c21782ab31293922a6195e0df7da30a369a1396328ace5251
+DIST cpl-7.0.tar.gz 3090767 SHA256 8b0351225ebe845fa496154c4a87564323bad8bf6223e25e90290b4a608127aa SHA512 d79eb37a5f29740edc1736815bde6ec31bc4e1f648552cad48ab70626170ff6195d226de0c198e0287dee3bfe815ee7302b6882395d710c534fabe0c5353aaa6 WHIRLPOOL 791d56d4b10bdd226798392cb82a6361893d673d5853f6a03ec50608a12823d4f3e5f219bebf3be5147db6b1b90c24860c6f947de3d339e3626d9f5627b8fa37
diff --git a/sci-astronomy/cpl/cpl-7.0.ebuild b/sci-astronomy/cpl/cpl-7.0.ebuild
new file mode 100644
index 000000000000..0d464b8c300d
--- /dev/null
+++ b/sci-astronomy/cpl/cpl-7.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+JAVA_PKG_OPT_USE=gasgano
+
+inherit autotools java-pkg-opt-2
+
+DESCRIPTION="ESO common pipeline library for astronomical data reduction"
+HOMEPAGE="http://www.eso.org/sci/software/cpl/"
+SRC_URI="ftp://ftp.eso.org/pub/dfs/pipelines/libraries/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/26"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc gasgano static-libs threads"
+
+RDEPEND="
+ sci-astronomy/wcslib:0=
+ sci-libs/cfitsio:0=
+ sci-libs/fftw:3.0=
+ gasgano? ( sci-astronomy/gasgano )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.6.1-use-system-ltdl.patch
+)
+
+src_prepare() {
+ default
+ # remove cpu chcking
+ sed -e '/CPL_CHECK_CPU/d' \
+ -i configure.ac libcext/configure.ac || die
+ # search for shared libs, not static
+ sed -e 's/\.a/\.so/g' \
+ -i m4/cpl.m4 || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ --disable-ltdl-install
+ --without-included-ltdl
+ --with-cfitsio="${EPREFIX}/usr"
+ --with-wcs="${EPREFIX}/usr"
+ --with-fftw="${EPREFIX}/usr"
+ $(use_enable doc maintainer-mode)
+ $(use_enable static-libs static)
+ $(use_enable threads)
+ )
+ if use gasgano; then
+ myeconfargs+=(
+ --enable-gasgano
+ --with-gasgano="${EPREFIX}/usr"
+ --with-gasgano-classpath="${EPREFIX}/usr/share/gasgano/lib"
+ --with-java="$(java-config -O)"
+ )
+ else
+ myeconfargs+=( --disable-gasgano )
+ fi
+ econf ${myeconfargs[@]}
+}
+
+src_compile() {
+ default
+ use doc && emake html
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+ use doc && emake install-html
+}