summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-02-24 18:41:00 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-02-24 18:56:04 +0000
commiteb956109714922f5d37f8f7791365052c0e0a11c (patch)
tree1b87088ed352276ff76c12427bd35394582c00db /sci-astronomy/ds9-bin/ds9-bin-7.4.ebuild
parentx11-misc/set_opacity: adjust HOMEPAGE and live ebuild repo path, add upstream... (diff)
downloadgentoo-eb956109714922f5d37f8f7791365052c0e0a11c.tar.gz
gentoo-eb956109714922f5d37f8f7791365052c0e0a11c.tar.bz2
gentoo-eb956109714922f5d37f8f7791365052c0e0a11c.zip
sci-astronomy/ds9-bin: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'sci-astronomy/ds9-bin/ds9-bin-7.4.ebuild')
-rw-r--r--sci-astronomy/ds9-bin/ds9-bin-7.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-astronomy/ds9-bin/ds9-bin-7.4.ebuild b/sci-astronomy/ds9-bin/ds9-bin-7.4.ebuild
new file mode 100644
index 000000000000..7dbfbb558fe2
--- /dev/null
+++ b/sci-astronomy/ds9-bin/ds9-bin-7.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Data visualization application for astronomical FITS images"
+HOMEPAGE="http://ds9.si.edu/site/Home.html"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/ds9.png.tar
+ amd64? ( http://ds9.si.edu/download/linux64/ds9.linux64.${PV}.tar.gz )
+ x86? ( http://hea-www.harvard.edu/RD/ds9/download/linux/ds9.linux.${PV}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libxml2
+ media-libs/fontconfig
+ media-libs/freetype
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/xpa"
+
+DEPEND=""
+S="${WORKDIR}"
+
+QA_PRESTRIPPED="usr/bin/ds9"
+QA_PREBUILT="usr/bin/ds9"
+
+src_install () {
+ dobin ds9
+ doicon ds9.png
+ make_desktop_entry ds9 "SAOImage DS9" ds9
+}