summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-astronomy/kapteyn/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-astronomy/kapteyn/files')
-rw-r--r--sci-astronomy/kapteyn/files/kapteyn-2.2-debundle_wcs.patch101
1 files changed, 101 insertions, 0 deletions
diff --git a/sci-astronomy/kapteyn/files/kapteyn-2.2-debundle_wcs.patch b/sci-astronomy/kapteyn/files/kapteyn-2.2-debundle_wcs.patch
new file mode 100644
index 000000000000..035979b80bc7
--- /dev/null
+++ b/sci-astronomy/kapteyn/files/kapteyn-2.2-debundle_wcs.patch
@@ -0,0 +1,101 @@
+Use system wcslib
+
+Patch written by Kacper Kowalik <xarthisius@gentoo.org>
+
+--- a/setup.py
++++ b/setup.py
+@@ -3,7 +3,8 @@
+ from kapteyn import __version__ as version
+ from glob import glob
+ import sys, os
+-
++from subprocess import Popen, PIPE
++from re import match
+ try:
+ import numpy
+ except:
+@@ -14,21 +15,27 @@
+ '''
+ sys.exit(1)
+
+-try:
+- wcslib_dir = glob('src/wcslib*/C/')[0]
+-except:
+- print '''
+--- Error.
+-Unable to find WCSLIB source distribution.
+-'''
+- sys.exit(1)
++def pkgconfig(*packages, **kw):
++ flag_map = {'-I': 'include_dirs', '-L': 'library_dirs', '-l': 'libraries'}
++ arg = "--libs --cflags --modversion %s" % ' '.join(packages)
++ for tok in Popen(["pkg-config "+ arg],stdout=PIPE, shell=True).communicate()[0].split():
++ token = tok.decode("utf-8")
++ if(match("[0-9]",token)):
++ kw.setdefault("version",[]).append(token)
++ else:
++ kw.setdefault(flag_map.get(token[:2]), []).append(token[2:])
++ return kw
+
+ include_dirs = []
+ numdir = os.path.dirname(numpy.__file__)
+ ipath = os.path.join(numdir, numpy.get_include())
+ include_dirs.append(ipath)
+ include_dirs.append('src')
+-include_dirs.append(wcslib_dir)
++
++WCSLIB = pkgconfig('wcslib')
++WCSVERSION = Popen(["pkg-config --modversion"],stdout=PIPE, shell=True).communicate()[0].split()
++
++include_dirs += WCSLIB['include_dirs']
+
+ short_descr = "Kapteyn Package: Python modules for astronomical applications"
+
+@@ -94,27 +101,6 @@
+ "xyz.c"
+ ]
+
+-wcslib_src = [
+- "cel.c",
+- "lin.c",
+- "log.c",
+- "prj.c",
+- "spc.c",
+- "sph.c",
+- "spx.c",
+- "tab.c",
+- "wcs.c",
+- "wcsfix.c",
+- "wcshdr.c",
+- "wcsprintf.c",
+- "wcstrig.c",
+- "wcsunits.c",
+- "wcsutil.c",
+- "wcserr.c",
+- "flexed/wcsulex.c",
+- "flexed/wcsutrn.c"
+-]
+-
+ ndimg_src = [
+ "nd_image.c",
+ "ni_filters.c",
+@@ -125,8 +111,7 @@
+ "ni_support.c",
+ ]
+
+-wcs_src = ( ['src/' + source for source in wcsmod_src]
+- + [wcslib_dir + source for source in wcslib_src] )
++wcs_src = ( ['src/' + source for source in wcsmod_src] )
+
+ _nd_image_src = ['src/ndimg/' + source for source in ndimg_src]
+
+@@ -168,7 +153,8 @@
+ Extension(
+ "wcs", wcs_src,
+ include_dirs=include_dirs,
+- define_macros=define_macros
++ define_macros=define_macros,
++ libraries=WCSLIB['libraries']
+ ),
+ Extension(
+ "ascarray",