summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-02-24 23:42:23 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-02-24 23:42:50 +0000
commit11787a4915a7899c414a3ab0f4b487e8aac4c1a5 (patch)
tree37ce2707d94a5a440bc0bd3d10b8f0fefb9a1ba7 /sci-astronomy/pyephem/pyephem-3.7.6.0.ebuild
parentdev-python/pyregion: cleanup (diff)
downloadgentoo-11787a4915a7899c414a3ab0f4b487e8aac4c1a5.tar.gz
gentoo-11787a4915a7899c414a3ab0f4b487e8aac4c1a5.tar.bz2
gentoo-11787a4915a7899c414a3ab0f4b487e8aac4c1a5.zip
sci-astronomy/pyephem: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'sci-astronomy/pyephem/pyephem-3.7.6.0.ebuild')
-rw-r--r--sci-astronomy/pyephem/pyephem-3.7.6.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sci-astronomy/pyephem/pyephem-3.7.6.0.ebuild b/sci-astronomy/pyephem/pyephem-3.7.6.0.ebuild
new file mode 100644
index 000000000000..b9fe6e80d700
--- /dev/null
+++ b/sci-astronomy/pyephem/pyephem-3.7.6.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Astronomical routines for the python programming language"
+HOMEPAGE="http://rhodesmill.org/pyephem/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND="doc? ( dev-python/sphinx )"
+RDEPEND=""
+
+src_prepare() {
+ # don't install rst files by dfefault
+ sed -i -e "s:'doc/\*\.rst',::" setup.py || die
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ if use doc; then
+ PYTHONPATH=. emake -C ephem/doc html
+ fi
+}
+
+python_test() {
+ if [[ ${PYTHON_ABI} == "2.7" ]]; then
+ PYTHONPATH="$(ls -d ${BUILD_DIR}/lib*)" \
+ ${EPYTHON} -m unittest discover -s ephem
+ else
+ PYTHONPATH="$(ls -d ${BUILD_DIR}/lib*)" \
+ unit2 discover -s ephem
+ fi
+}
+
+src_install() {
+ use doc && HTML_DOCS=( ephem/doc/_build/html/. )
+ distutils-r1_src_install
+
+ delete_tests() {
+ rm -r "${D}$(python_get_sitedir)/ephem/tests" || die
+ }
+ python_foreach_impl delete_tests
+}