summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-02-29 20:44:13 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-02-29 23:12:59 +0000
commitdf61d4ce347c741e58f74b088ed257fd5182ca0e (patch)
treeabab059fcadba3f0a1ca529917f1e06afba3befd /sci-astronomy/sofa_c/sofa_c-20150209a.ebuild
parentsci-astronomy/idlastro: Version bump and cleanup (diff)
downloadgentoo-df61d4ce347c741e58f74b088ed257fd5182ca0e.tar.gz
gentoo-df61d4ce347c741e58f74b088ed257fd5182ca0e.tar.bz2
gentoo-df61d4ce347c741e58f74b088ed257fd5182ca0e.zip
sci-astronomy/sofa_c: Version bump and cleanup
Package-Manager: portage-2.2.27
Diffstat (limited to 'sci-astronomy/sofa_c/sofa_c-20150209a.ebuild')
-rw-r--r--sci-astronomy/sofa_c/sofa_c-20150209a.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-astronomy/sofa_c/sofa_c-20150209a.ebuild b/sci-astronomy/sofa_c/sofa_c-20150209a.ebuild
new file mode 100644
index 000000000000..39ee91a668d1
--- /dev/null
+++ b/sci-astronomy/sofa_c/sofa_c-20150209a.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+YYYY=${PV:0:4}
+MMDD=${PV:4:4}
+MYPV=${YYYY}${MMDD}_${PV:8:1}
+
+DESCRIPTION="Library for algorithms for models in fundamental astronomy"
+HOMEPAGE=" http://www.iausofa.org/current_C.html"
+SRC_URI="http://www.iausofa.org/${YYYY}_${MMDD}_C/${PN}-${MYPV}.tar.gz"
+
+LICENSE="SOFA"
+SLOT=0
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND=""
+
+PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
+
+S="${WORKDIR}/sofa/${MYPV}/c/src"
+
+src_prepare() {
+ default
+ sed -i -e "s:/lib:/$(get_libdir):" makefile || die
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ cd ..
+ dodoc 00READ.ME
+ use doc && dodoc doc/*.lis doc/*.pdf
+}