summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-27 04:52:44 +0000
committerSam James <sam@gentoo.org>2021-02-27 04:52:44 +0000
commit56ab65de7dfe1d8de3aa2e932426386fe9f3e947 (patch)
tree1492abd959f606e7035dd1c01ab5d726fbcadbaf /sci-astronomy/stiff
parentmedia-libs/libbluray: fix gcc 10 build (diff)
downloadgentoo-56ab65de7dfe1d8de3aa2e932426386fe9f3e947.tar.gz
gentoo-56ab65de7dfe1d8de3aa2e932426386fe9f3e947.tar.bz2
gentoo-56ab65de7dfe1d8de3aa2e932426386fe9f3e947.zip
sci-astronomy/stiff: fix gcc 10 build
Closes: https://bugs.gentoo.org/708382 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-astronomy/stiff')
-rw-r--r--sci-astronomy/stiff/stiff-2.4.0.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/sci-astronomy/stiff/stiff-2.4.0.ebuild b/sci-astronomy/stiff/stiff-2.4.0.ebuild
index 5d5e1701b58f..85bdc78a39f9 100644
--- a/sci-astronomy/stiff/stiff-2.4.0.ebuild
+++ b/sci-astronomy/stiff/stiff-2.4.0.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
if [[ ${PV} == "9999" ]] ; then
inherit subversion
ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
- SRC_URI=""
else
+ inherit flag-o-matic
SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
fi
@@ -25,8 +25,16 @@ RDEPEND="
sys-libs/zlib:0="
DEPEND="${RDEPEND}"
+src_prepare() {
+ default
+
+ # bug #708382
+ append-cflags -fcommon
+}
+
src_configure() {
- ECONF_SOURCE="${S}" econf $(use_enable threads)
+ CONFIG_SHELL="${EPREFIX}/bin/bash" ECONF_SOURCE="${S}" econf \
+ $(use_enable threads)
}
src_install() {