summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-06-10 17:06:17 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-06-10 17:12:20 +0000
commitf77ad5634d6f37f9f2f17e7d97c7adf06471675b (patch)
tree4d14dfe10df07bd9b96829961020b1a1bb5cfa65 /sci-astronomy/wcstools/wcstools-3.9.3.ebuild
parentnet-misc/lldpd: Clear out old ebuild for 0.9.3 (diff)
downloadgentoo-f77ad5634d6f37f9f2f17e7d97c7adf06471675b.tar.gz
gentoo-f77ad5634d6f37f9f2f17e7d97c7adf06471675b.tar.bz2
gentoo-f77ad5634d6f37f9f2f17e7d97c7adf06471675b.zip
sci-astronomy/wcstools: Version bump
Added 3 extra patches (from Debian) to take care of various leaks. Removed leaky versions. Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'sci-astronomy/wcstools/wcstools-3.9.3.ebuild')
-rw-r--r--sci-astronomy/wcstools/wcstools-3.9.3.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/sci-astronomy/wcstools/wcstools-3.9.3.ebuild b/sci-astronomy/wcstools/wcstools-3.9.3.ebuild
new file mode 100644
index 000000000000..8d483f01c558
--- /dev/null
+++ b/sci-astronomy/wcstools/wcstools-3.9.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils autotools
+
+DESCRIPTION="World Coordinate System library for astronomical FITS images"
+HOMEPAGE="http://tdc-www.harvard.edu/software/wcstools"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DOCS=( Readme Programs NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.9.2-compiler_warnings.patch
+ "${FILESDIR}"/${PN}-3.9.2-mayhem.patch
+ "${FILESDIR}"/${PN}-3.9.2-RASortStars.patch
+ "${FILESDIR}"/${PN}-3.9.2-spelling.patch
+ "${FILESDIR}"/${PN}-3.9.2-sprintf.patch
+ "${FILESDIR}"/${PN}-3.9.2-use_abort.patch
+ "${FILESDIR}"/${PN}-3.9.2-wcsinit_crash.patch
+ "${FILESDIR}"/${PN}-3.9.2-additional_pointer_increase.patch
+ "${FILESDIR}"/${PN}-3.9.2-ctype_copy_to_wcs.patch
+ "${FILESDIR}"/${PN}-3.9.2-off-by-one-allocation.patch
+)
+
+src_prepare() {
+ default
+ einfo "Copying gentoo autotools files"
+ local f
+ for f in "${FILESDIR}"/{configure.ac,wcstools.pc.in,Makefile.am}; do
+ cp ${f} "${S}"/ || die
+ done
+ cp "${FILESDIR}"/Makefile.libwcs.am "${S}"/libwcs/Makefile.am || die
+ # avoid colliding with fixdos, getdate and remap from other packages
+ sed -i \
+ -e 's/getdate/wcsgetdate/' \
+ -e 's/crlf/wcscrlf/' \
+ -e 's/remap/wcsremap/' \
+ -e "s/3.... Programs/${PV} Programs/" \
+ wcstools || die
+ eautoreconf
+}
+
+src_test() {
+ einfo "Testing various wcstools programs"
+ ./newfits -a 10 -j 248 41 -p 0.15 test.fits || die "test newfits failed"
+ ./sethead test.fits A=1 B=1 || die "test sethead failed"
+ [[ "$(./gethead test.fits RA)" == "16:32:00.0000" ]] \
+ || die "test gethead failed"
+ rm test.fits
+}
+
+src_install() {
+ default
+ doman man/man1/*
+ newdoc libwcs/NEWS NEWS.libwcs
+ newdoc libwcs/Readme Readme.libwcs
+
+}
+
+pkg_postinst() {
+ elog "The following execs have been renamed to avoid colliding"
+ elog "with other packages:"
+ elog " getdate -> wcsgetdate"
+ elog " crlf -> wcscrlf"
+ elog " remap -> wcsremap"
+}