summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2020-07-03 10:31:28 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-02-13 14:09:24 +0100
commit7a219ed6d9281845e0c6d137a4154a2551bb8750 (patch)
tree91d3970ecdd607466615d5f681f995235cc0c1a5 /sci-astronomy/xephem
parentsci-astronomy/xephem: use HTTPS, add missing eclass (diff)
downloadgentoo-7a219ed6d9281845e0c6d137a4154a2551bb8750.tar.gz
gentoo-7a219ed6d9281845e0c6d137a4154a2551bb8750.tar.bz2
gentoo-7a219ed6d9281845e0c6d137a4154a2551bb8750.zip
sci-astronomy/xephem: EAPI7 bump, fix SRC_URI
Closes: https://github.com/gentoo/gentoo/pull/16560 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sci-astronomy/xephem')
-rw-r--r--sci-astronomy/xephem/Manifest1
-rw-r--r--sci-astronomy/xephem/xephem-3.7.7-r1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/sci-astronomy/xephem/Manifest b/sci-astronomy/xephem/Manifest
index 74103178646a..b962d072292f 100644
--- a/sci-astronomy/xephem/Manifest
+++ b/sci-astronomy/xephem/Manifest
@@ -1 +1,2 @@
DIST xephem-3.7.7.tar.gz 18128523 BLAKE2B 85173bfb21e31198aab9231f6020267beadd4750c832d514f06983ea9c88487c4175d3ac0e7b973a8fb41785658e0155e23be6cb89ac370f9a908e6eff8ea5e8 SHA512 d9cfecf0ce8aa495f66fcf6772ca7df0638cef8b9f18d9d6cbf013846a7575786ae9b5c515abc2058783baa7610320c893ddbc6f68bae28c65661a1c73b88634
+DIST xephem-3.7.7.tgz 18128521 BLAKE2B a7d0ee2cf1be64f79ed0c5cea6d37e48c69875de5b3c9592554ee8be25b369e964c7a6bb05690ef28893b7af8277daf39ba85538f56852f35538180f9ad0c2ba SHA512 0a21f783a0a543f19a527afb87647ff2e988c6a426a37e01b9a3d1d76a9ee74125ce802e2dbc5e13034f11ef897e6188cb5b0bb92bc0d35db0fb8839e0c53157
diff --git a/sci-astronomy/xephem/xephem-3.7.7-r1.ebuild b/sci-astronomy/xephem/xephem-3.7.7-r1.ebuild
new file mode 100644
index 000000000000..6b0253ce91eb
--- /dev/null
+++ b/sci-astronomy/xephem/xephem-3.7.7-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop toolchain-funcs
+
+DESCRIPTION="Interactive tool for astronomical ephemeris and sky simulation"
+HOMEPAGE="https://www.clearskyinstitute.com/xephem"
+SRC_URI="https://www.clearskyinstitute.com/xephem/${P}.tgz"
+
+LICENSE="XEphem"
+SLOT=0
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=x11-libs/motif-2.3:0
+ virtual/jpeg:0
+ media-libs/libpng:0="
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/groff"
+
+HTML_DOCS=( GUI/xephem/help/. )
+DOCS=( README )
+
+PATCHES=(
+ "${FILESDIR}/${P}-respect_env_vars.patch"
+ "${FILESDIR}/${P}-implicits.patch"
+ "${FILESDIR}/${P}-no_xprint.patch"
+)
+
+src_compile() {
+ tc-export CC AR RANLIB
+ emake -C GUI/xephem
+}
+
+src_install() {
+ insinto /usr/share/X11/app-defaults
+ newins - XEphem <<-EOF
+ XEphem.ShareDir: /usr/share/${PN}
+ EOF
+ newenvd - 99xephem <<-EOF
+ XEHELPURL=/usr/share/doc/${PF}/html/xephem.html
+ EOF
+ einstalldocs
+
+ cd GUI/xephem || die
+ dobin xephem
+ doman xephem.1
+ newicon XEphem.png ${PN}.png
+ insinto /usr/share/${PN}
+ doins -r auxil catalogs fifos fits gallery lo
+ make_desktop_entry xephem XEphem ${PN}
+}