summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /sci-astronomy
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/casacore/casacore-2.3.0-r1.ebuild1
-rw-r--r--sci-astronomy/healpix/healpix-3.30.ebuild3
-rw-r--r--sci-astronomy/healpix/healpix-3.31.ebuild3
-rw-r--r--sci-astronomy/sextractor/sextractor-2.19.5-r1.ebuild3
-rw-r--r--sci-astronomy/sextractor/sextractor-2.19.5.ebuild3
-rw-r--r--sci-astronomy/stellarium/stellarium-0.19.0.ebuild1
-rw-r--r--sci-astronomy/stellarium/stellarium-0.19.1.ebuild1
7 files changed, 11 insertions, 4 deletions
diff --git a/sci-astronomy/casacore/casacore-2.3.0-r1.ebuild b/sci-astronomy/casacore/casacore-2.3.0-r1.ebuild
index ad8c81cb25f3..53af61053de3 100644
--- a/sci-astronomy/casacore/casacore-2.3.0-r1.ebuild
+++ b/sci-astronomy/casacore/casacore-2.3.0-r1.ebuild
@@ -15,6 +15,7 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
SLOT="0"
IUSE="+c++11 +data doc fftw hdf5 openmp python threads test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
diff --git a/sci-astronomy/healpix/healpix-3.30.ebuild b/sci-astronomy/healpix/healpix-3.30.ebuild
index e446fc060467..230301b8aa09 100644
--- a/sci-astronomy/healpix/healpix-3.30.ebuild
+++ b/sci-astronomy/healpix/healpix-3.30.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,6 +18,7 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
# might add fortran in the future if requested
IUSE="cxx doc idl java openmp static-libs test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=sci-libs/cfitsio-3
diff --git a/sci-astronomy/healpix/healpix-3.31.ebuild b/sci-astronomy/healpix/healpix-3.31.ebuild
index 489986685793..0b4c98015d13 100644
--- a/sci-astronomy/healpix/healpix-3.31.ebuild
+++ b/sci-astronomy/healpix/healpix-3.31.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,6 +18,7 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
# might add fortran in the future if requested
IUSE="cxx doc idl java openmp static-libs test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=sci-libs/cfitsio-3
diff --git a/sci-astronomy/sextractor/sextractor-2.19.5-r1.ebuild b/sci-astronomy/sextractor/sextractor-2.19.5-r1.ebuild
index a3aae82d8cdf..becaa0b3c081 100644
--- a/sci-astronomy/sextractor/sextractor-2.19.5-r1.ebuild
+++ b/sci-astronomy/sextractor/sextractor-2.19.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,6 +16,7 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="doc modelfit test threads"
+RESTRICT="!test? ( test )"
RDEPEND="
!games-misc/sex
diff --git a/sci-astronomy/sextractor/sextractor-2.19.5.ebuild b/sci-astronomy/sextractor/sextractor-2.19.5.ebuild
index 3aeded5ecbc8..8d374bc1d699 100644
--- a/sci-astronomy/sextractor/sextractor-2.19.5.ebuild
+++ b/sci-astronomy/sextractor/sextractor-2.19.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,6 +16,7 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="doc modelfit test threads"
+RESTRICT="!test? ( test )"
RDEPEND="
modelfit? ( sci-libs/atlas[lapack,threads=] sci-libs/fftw:3.0 )"
diff --git a/sci-astronomy/stellarium/stellarium-0.19.0.ebuild b/sci-astronomy/stellarium/stellarium-0.19.0.ebuild
index 9d606e663e33..c0fa7fde1868 100644
--- a/sci-astronomy/stellarium/stellarium-0.19.0.ebuild
+++ b/sci-astronomy/stellarium/stellarium-0.19.0.ebuild
@@ -21,6 +21,7 @@ LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
IUSE="debug gps media nls stars test"
+RESTRICT="!test? ( test )"
BDEPEND="
nls? ( dev-qt/linguist-tools:5 )
diff --git a/sci-astronomy/stellarium/stellarium-0.19.1.ebuild b/sci-astronomy/stellarium/stellarium-0.19.1.ebuild
index b47582c27bac..43dd151870e1 100644
--- a/sci-astronomy/stellarium/stellarium-0.19.1.ebuild
+++ b/sci-astronomy/stellarium/stellarium-0.19.1.ebuild
@@ -21,6 +21,7 @@ LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="debug gps media nls stars test"
+RESTRICT="!test? ( test )"
BDEPEND="
nls? ( dev-qt/linguist-tools:5 )