summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-01-18 11:14:01 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-18 11:14:01 +0100
commitf8bd744e829cb173e8e424741a9a854205c80653 (patch)
treecae387b72cbafc3f22228eb82ee2a6eeb68d3058 /sci-astronomy
parentsci-astronomy/sofa_c: Remove old (diff)
downloadgentoo-f8bd744e829cb173e8e424741a9a854205c80653.tar.gz
gentoo-f8bd744e829cb173e8e424741a9a854205c80653.tar.bz2
gentoo-f8bd744e829cb173e8e424741a9a854205c80653.zip
sci-astronomy/healpix: Remove old
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/healpix/Manifest1
-rw-r--r--sci-astronomy/healpix/healpix-3.30.ebuild141
2 files changed, 0 insertions, 142 deletions
diff --git a/sci-astronomy/healpix/Manifest b/sci-astronomy/healpix/Manifest
index f12c14d88a13..f4344c29ce19 100644
--- a/sci-astronomy/healpix/Manifest
+++ b/sci-astronomy/healpix/Manifest
@@ -1,2 +1 @@
-DIST Healpix_3.30_2015Oct08.tar.gz 23465221 BLAKE2B c11b681065a2baf951c82538c6c47459954e1702153d55c1983af245ac4748f7768b43ab5c44f4a7b914c15cd4c23ee176389f18cbbee02923a76d69444542d1 SHA512 a7be82687a2188f5dff99c6826355e3290ccc91cc440e67267c58fa13af9fa5d301eca9b37676ef6f0af262b2ff1c06e722d0dcd3aca00a4c9d2794bc666c0c7
DIST Healpix_3.31_2016Aug26.tar.gz 23834899 BLAKE2B a9e3b6567e851eb941e81d45145848a8daede260454dee29e056857f98ea643a0a438a5cc763651f4156ae975be41c601b8664f8bebbcf13b0fb23822c36ae40 SHA512 fd80e9ed80d19e438134f63c3d13802f63c4cd1b9f3596807e67d4ba5ff814e652a130d038449269d6ead271085eb0ab74884b2d768d8531066727377c457f9c
diff --git a/sci-astronomy/healpix/healpix-3.30.ebuild b/sci-astronomy/healpix/healpix-3.30.ebuild
deleted file mode 100644
index 162cf1eee15e..000000000000
--- a/sci-astronomy/healpix/healpix-3.30.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools toolchain-funcs eutils java-pkg-opt-2 java-ant-2 ltprune
-
-MYP="Healpix_${PV}"
-MYPF=${MYP}_2015Oct08
-
-DESCRIPTION="Hierarchical Equal Area isoLatitude Pixelization of a sphere"
-HOMEPAGE="http://healpix.sourceforge.net/"
-SRC_URI="mirror://sourceforge/healpix/${MYP}/${MYPF}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-# might add fortran in the future if requested
-IUSE="cxx doc idl java openmp static-libs test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=sci-libs/cfitsio-3
- idl? (
- dev-lang/gdl
- sci-astronomy/idlastro )
- java? ( >=virtual/jre-1.6:* )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- java? ( >=virtual/jdk-1.6:* test? ( dev-java/ant-junit4:0 ) )"
-
-S="${WORKDIR}/${MYP}"
-
-pkg_pretend() {
- if use cxx && use openmp && [[ $(tc-getCXX)$ == *g++* ]] && [[ ${MERGE_TYPE} != binary ]]; then
- tc-has-openmp || \
- die "You are using gcc but without OpenMP capabilities that you requested"
- fi
-}
-
-pkg_setup() {
- java-pkg-opt-2_pkg_setup
-}
-
-src_prepare() {
- pushd src/C/autotools > /dev/null
- eautoreconf
- popd > /dev/null
- # why was static-libtool-libs forced?
- if use cxx; then
- pushd src/cxx/autotools > /dev/null
- sed -i -e '/-static-libtool-libs/d' Makefile.am || die
- eautoreconf
- popd > /dev/null
- fi
- # duplicate of idlastro (in rdeps)
- rm -r src/idl/zzz_external/astron || die
- mv src/idl/zzz_external/README src/idl/README.external || die
- java-pkg-opt-2_src_prepare
- default
-}
-
-src_configure() {
- pushd src/C/autotools > /dev/null
- econf $(use_enable static-libs static)
- popd > /dev/null
- if use cxx; then
- pushd src/cxx/autotools > /dev/null
- econf \
- --disable-native-optimizations \
- $(use_enable openmp) \
- $(use_enable static-libs static)
- popd > /dev/null
- fi
-}
-
-src_compile() {
- pushd src/C/autotools > /dev/null
- emake
- popd > /dev/null
- if use cxx; then
- pushd src/cxx/autotools > /dev/null
- emake
- popd > /dev/null
- fi
- if use java; then
- pushd src/java > /dev/null
- eant dist-notest
- popd > /dev/null
- fi
-}
-
-src_test() {
- pushd src/C/autotools > /dev/null
- emake check
- popd > /dev/null
- if use cxx; then
- pushd src/cxx/autotools > /dev/null
- emake check
- popd > /dev/null
- fi
- if use java; then
- pushd src/java > /dev/null
- EANT_GENTOO_CLASSPATH="ant-junit4" ANT_TASKS="ant-junit4" eant test
- popd > /dev/null
- fi
-}
-
-src_install() {
- dodoc READ_Copyrights_Licenses.txt
- pushd src/C/autotools > /dev/null
- emake install DESTDIR="${D}"
- popd > /dev/null
- if use cxx; then
- pushd src/cxx/autotools > /dev/null
- emake install DESTDIR="${D}"
- docinto cxx
- dodoc ../CHANGES
- popd > /dev/null
- fi
- use static-libs || prune_libtool_files --all
- if use idl; then
- pushd src/idl > /dev/null
- insinto /usr/share/gnudatalanguage/healpix
- doins -r examples fits interfaces misc toolkit visu zzz_external
- doins HEALPix_startup
- docinto idl
- dodoc README.*
- popd > /dev/null
- fi
- if use java; then
- pushd src/java > /dev/null
- java-pkg_dojar dist/*.jar
- docinto java
- dodoc README CHANGES
- popd > /dev/null
- fi
- use doc && dodoc -r doc/html
-}