summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-25 19:45:25 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-25 20:18:26 +0100
commit3b77d415ff6c692b3e08907626656f0112f22108 (patch)
tree2504030d4c96eec1aaf38df69802ffaa619dfd2a /sci-biology/amos
parentsci-biology/amos: Use python-single-r1 instead of python-r1 (diff)
downloadgentoo-3b77d415ff6c692b3e08907626656f0112f22108.tar.gz
gentoo-3b77d415ff6c692b3e08907626656f0112f22108.tar.bz2
gentoo-3b77d415ff6c692b3e08907626656f0112f22108.zip
sci-biology/amos: Remove old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-biology/amos')
-rw-r--r--sci-biology/amos/amos-3.1.0-r2.ebuild48
-rw-r--r--sci-biology/amos/amos-3.1.0.ebuild29
2 files changed, 0 insertions, 77 deletions
diff --git a/sci-biology/amos/amos-3.1.0-r2.ebuild b/sci-biology/amos/amos-3.1.0-r2.ebuild
deleted file mode 100644
index 91c1f69f9756..000000000000
--- a/sci-biology/amos/amos-3.1.0-r2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit flag-o-matic python-r1
-
-DESCRIPTION="A Modular, Open-Source whole genome assembler"
-HOMEPAGE="http://amos.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- https://dev.gentoo.org/~soap/distfiles/${PN}-3.1.0-fix-c++14.patch.bz2"
-
-LICENSE="Artistic"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="qt4"
-
-DEPEND="qt4? ( dev-qt/qtcore:4 )"
-RDEPEND="${DEPEND}
- dev-perl/DBI
- dev-perl/Statistics-Descriptive
- sci-biology/mummer"
-
-PATCHES=(
- "${FILESDIR}"/${P}-gcc-4.7.patch
- "${FILESDIR}"/${P}-goBambus2.py-indent-and-cleanup.patch
- "${WORKDIR}"/${P}-fix-c++14.patch
- "${FILESDIR}"/${P}-qa-Wformat.patch
-)
-
-src_configure() {
- # prevent GCC 6 log pollution due to hash_map deprecation in C++11
- append-cxxflags -Wno-cpp
-
- default
-}
-
-src_compile() {
- emake -j1
-}
-
-src_install() {
- default
- python_replicate_script "${ED%/}/usr/bin/goBambus2"
-}
diff --git a/sci-biology/amos/amos-3.1.0.ebuild b/sci-biology/amos/amos-3.1.0.ebuild
deleted file mode 100644
index 945ec9f41b4c..000000000000
--- a/sci-biology/amos/amos-3.1.0.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit eutils
-
-DESCRIPTION="A Modular, Open-Source whole genome assembler"
-HOMEPAGE="http://amos.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="Artistic"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="qt4"
-
-DEPEND="qt4? ( dev-qt/qtcore:4 )"
-RDEPEND="${DEPEND}
- dev-perl/DBI
- dev-perl/Statistics-Descriptive
- sci-biology/mummer"
-
-MAKEOPTS+=" -j1"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-gcc-4.7.patch
-}