summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-24 10:05:56 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-24 13:10:17 +0100
commitbc99ac146dd8201046b387ff79ac15c949db75cb (patch)
treeddccc3b2e359490ad9d73fb061bd77b7a66f471e /sci-biology/biopandas/biopandas-0.1.4.ebuild
parentdev-python/httplib2: Add python3.5 support (diff)
downloadgentoo-bc99ac146dd8201046b387ff79ac15c949db75cb.tar.gz
gentoo-bc99ac146dd8201046b387ff79ac15c949db75cb.tar.bz2
gentoo-bc99ac146dd8201046b387ff79ac15c949db75cb.zip
sci-biology/biopandas: New package, ebuild written by me
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-biology/biopandas/biopandas-0.1.4.ebuild')
-rw-r--r--sci-biology/biopandas/biopandas-0.1.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-biology/biopandas/biopandas-0.1.4.ebuild b/sci-biology/biopandas/biopandas-0.1.4.ebuild
new file mode 100644
index 000000000000..76ac9d7c1228
--- /dev/null
+++ b/sci-biology/biopandas/biopandas-0.1.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+MY_PN="BioPandas"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Molecular Structures in Pandas DataFrames"
+HOMEPAGE="
+ https://rasbt.github.io/biopandas/
+ https://github.com/rasbt/biopandas
+ https://pypi.python.org/pypi/BioPandas"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${REDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" --version
+ "${EPYTHON}" -c "import numpy; print('numpy %s' % numpy.__version__)"
+ "${EPYTHON}" -c "import scipy; print('scipy %s' % scipy.__version__)"
+ "${EPYTHON}" -c "import pandas; print('pandas %s' % pandas.__version__)"
+ nosetests -s --verbose ${PN} || die
+}