summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-04-21 14:19:03 +0200
committerDavid Seifert <soap@gentoo.org>2019-04-21 14:19:03 +0200
commit2838d71e279cd5d3975c88bc52d2ee43bf820f50 (patch)
tree9e1de0662ee9101d12a576866800c7abeed8a37a /sci-biology/biopython
parentdev-python/rdflib: Add python3_7 to PYTHON_COMPAT (diff)
downloadgentoo-2838d71e279cd5d3975c88bc52d2ee43bf820f50.tar.gz
gentoo-2838d71e279cd5d3975c88bc52d2ee43bf820f50.tar.bz2
gentoo-2838d71e279cd5d3975c88bc52d2ee43bf820f50.zip
sci-biology/biopython: Bump to version 1.73
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology/biopython')
-rw-r--r--sci-biology/biopython/Manifest1
-rw-r--r--sci-biology/biopython/biopython-1.73.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sci-biology/biopython/Manifest b/sci-biology/biopython/Manifest
index 70af7c92d44d..02d90810dc5f 100644
--- a/sci-biology/biopython/Manifest
+++ b/sci-biology/biopython/Manifest
@@ -1,2 +1,3 @@
DIST biopython-1.68.tar.gz 14445813 BLAKE2B 566931c4e522e95278f7f6a9dc07ecc091dc54b69cdea8bb07603339af4f1fd38e3df87482e97729acb776dd2df19a4e61d49ee7608ec5cb0f24966e28c2e3dd SHA512 0ca994475654bb68ff326c8e86cbd4547cd87b42e1633dda039ad668e1298884b22e169f6b25ab514e929861334a93b7db6d057a3486cea9997ca2de95c61a69
DIST biopython-1.71.tar.gz 16031832 BLAKE2B 2062065b77fc35ea8a3f09ec967482c233a6e0bbfc7d09187ff5e892848b45fa7bd6d7b6027b38c3d4c9a9c601785521fa7edb91fa960b46c8e49aed91b1f5dc SHA512 003955e92295e98526c88abb573db9bdc37877fc41395551b541e7106ffa603327a36c6f4d999838c0be38b378901235c9dbd7cb7fc25c14a5d7001939fe23bd
+DIST biopython-1.73.tar.gz 15715102 BLAKE2B b2c40f9ed02681f19607c88f91b469784985acefc6e81770a54e5c13c715915344bc7fd72e4a88ae50879a2463965ac6d0d04c6d263908887028d1e065620b95 SHA512 d067330ef8e25ca6881b56f4e5e89e16a816c89760473e2f32a6236ab202f805294650aa944f0b098987425bcb65727317da7a26deb4d4937f02b00123ea9a8f
diff --git a/sci-biology/biopython/biopython-1.73.ebuild b/sci-biology/biopython/biopython-1.73.ebuild
new file mode 100644
index 000000000000..f0d335a5933a
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.73.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python modules for computational molecular biology"
+HOMEPAGE="https://www.biopython.org/ https://pypi.org/project/biopython/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/rdflib[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ >=dev-python/reportlab-3.5.13-r1[${PYTHON_USEDEP}]
+ dev-python/pydot[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sys-devel/flex"
+
+DOCS=( {CONTRIB,DEPRECATED,NEWS,README}.rst Doc/. )
+
+python_test() {
+ distutils_install_for_testing
+ cp -r "${S}"/{Doc,Tests} "${TEST_DIR}"/lib/ || die
+ cd "${TEST_DIR}"/lib/Tests || die
+ rm test_BioSQL_{psycopg2.py,MySQLdb.py,mysql_connector.py} || die
+ "${EPYTHON}" run_tests.py --offline --verbose || die
+}
+
+python_install_all() {
+ # remove files causing ecompressdir to fail
+ rm Doc/examples/ls_orchid.gbk.{gz,bz2} || die
+
+ distutils-r1_python_install_all
+
+ dodir /usr/share/${PN}
+ cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
+}
+
+pkg_postinst() {
+ elog "For database support you need to install:"
+ optfeature "MySQL" dev-python/mysql-python
+ optfeature "PostgreSQL" dev-python/psycopg
+
+ elog "Some applications need extra packages:"
+ optfeature "EMBOSS (The European Molecular Biology Open Software Suite)" sci-biology/emboss
+}