summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/biopython
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/biopython')
-rw-r--r--sci-biology/biopython/Manifest1
-rw-r--r--sci-biology/biopython/biopython-1.65.ebuild56
-rw-r--r--sci-biology/biopython/files/biopython-1.65-test-fix-backport.patch40
-rw-r--r--sci-biology/biopython/metadata.xml5
4 files changed, 102 insertions, 0 deletions
diff --git a/sci-biology/biopython/Manifest b/sci-biology/biopython/Manifest
new file mode 100644
index 000000000000..e835e2490342
--- /dev/null
+++ b/sci-biology/biopython/Manifest
@@ -0,0 +1 @@
+DIST biopython-1.65.tar.gz 12641342 SHA256 463cc81db84e9bfcdfb15629511c81ed556a6c0287e670dbfe80f03c65d2a88e SHA512 2a9c6a89d0279374c243938d13bfdd6f2b124a08afbfb0c262e1e4827c48a141fb9941f4cdb960f76b523f0ac152095a8c6ea566d9b469ce9daf8a7e7993f7af WHIRLPOOL 40757938c0eb7e30c9609ef5aa2d397fa21ad92cd20c9b6300cde1b381a0e6c21e4ebb7f4d25bf02651789437d7d86341154b907ccc0007759c17939f2e29da2
diff --git a/sci-biology/biopython/biopython-1.65.ebuild b/sci-biology/biopython/biopython-1.65.ebuild
new file mode 100644
index 000000000000..9c23f0bd0635
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.65.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python modules for computational molecular biology"
+HOMEPAGE="http://www.biopython.org/ http://pypi.python.org/pypi/biopython/"
+SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[$(python_gen_usedep 'python*')]
+ dev-python/networkx[$(python_gen_usedep 'python*')]
+ dev-python/numpy[$(python_gen_usedep 'python*')]
+ dev-python/rdflib[$(python_gen_usedep 'python*')]
+ dev-python/pygraphviz[$(python_gen_usedep 'python2*')]
+ dev-python/reportlab[$(python_gen_usedep 'python*')]
+ media-gfx/pydot[$(python_gen_usedep 'python2*')]
+ "
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+DOCS=( CONTRIB DEPRECATED NEWS README Doc/. )
+
+PATCHES=( "${FILESDIR}"/${P}-test-fix-backport.patch )
+
+python_test() {
+ [[ ${EPYTHON} == pypy ]] && return
+ cd Tests || die
+ ${PYTHON} run_tests.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dodir /usr/share/${PN}
+ cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
+}
+
+pkg_postinst() {
+ elog "For database support you need to install:"
+ optfeature "MySQL" dev-python/mysql-python
+ optfeature "PostGreSQL" dev-python/psycopg
+ echo
+ elog "Some applications need extra packages:"
+ optfeature "EMBOSS (The European Molecular Biology Open Software Suite)" sci-biology/emboss
+}
diff --git a/sci-biology/biopython/files/biopython-1.65-test-fix-backport.patch b/sci-biology/biopython/files/biopython-1.65-test-fix-backport.patch
new file mode 100644
index 000000000000..2efdef97d799
--- /dev/null
+++ b/sci-biology/biopython/files/biopython-1.65-test-fix-backport.patch
@@ -0,0 +1,40 @@
+From 08c72f8778a87701586a03dffcce33c7589bc6d7 Mon Sep 17 00:00:00 2001
+From: Peter Cock <p.j.a.cock@googlemail.com>
+Date: Sun, 18 Jan 2015 02:07:54 +0000
+Subject: [PATCH] Clearer error message; update failing test.
+
+One of the orchid examples now returns different enough
+results that the test was failing. The new error message
+makes it much easier to pick another positive example to
+add to the the white-list.
+---
+ Tests/test_NCBI_qblast.py | 9 +++++----
+ 1 file changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/Tests/test_NCBI_qblast.py b/Tests/test_NCBI_qblast.py
+index 88bfe61..19f7b35 100644
+--- a/Tests/test_NCBI_qblast.py
++++ b/Tests/test_NCBI_qblast.py
+@@ -66,7 +66,7 @@ def test_orchid_est(self):
+ AGCCATGGATTTCTCAGAAGAAAATGATTATACTTCTTAATCAGGCAACTGATATTATCAATTTATGGCA
+ GCAGAGTGGTGGCTCCTTGTCCCAGCAGCAGTAATTACTTTTTTTTCTCTTTTTGTTTCCAAATTAAGAA
+ ACATTAGTATCATATGGCTATTTGCTCAATTGCAGATTTCTTTCTTTTGTGAATG""",
+- 0.0000001, None, ["21554275", "18409071", "296087288"])
++ 0.0000001, None, ["21554275", "18409071", "296087288", "566183510"])
+
+ def run_qblast(self, program, database, query, e_value, entrez_filter, expected_hits):
+ try:
+@@ -120,9 +120,10 @@ def run_qblast(self, program, database, query, e_value, entrez_filter, expected_
+ print("Update this test to have some redundancy...")
+ for alignment in record.alignments:
+ print(alignment.hit_id)
+- assert found_result, "Missing all of %s in alignments" \
+- % ", ".join(expected_hits)
+- self.assertTrue(found_result)
++ self.assertTrue(found_result,
++ "Missing all expected hits (%s), instead have: %s"
++ % (", ".join(expected_hits),
++ ", ".join(a.hit_id for a in record.alignments)))
+
+ # Check the expected result(s) are found in the descriptions
+ if expected_hits is None:
diff --git a/sci-biology/biopython/metadata.xml b/sci-biology/biopython/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/biopython/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>