summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Tanberry <ted.tanberry@gmail.com>2015-10-10 21:04:45 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-14 14:47:58 +0200
commitddbfba3594bda0b32f359e057555d477ffbced1e (patch)
treeea878cf553eda9db8df5ca4d710fd83d4ef22f54 /sci-biology/bowtie/files
parentx11-libs/gdk-pixbuf: run glibc-specific test only on glibc (diff)
downloadgentoo-ddbfba3594bda0b32f359e057555d477ffbced1e.tar.gz
gentoo-ddbfba3594bda0b32f359e057555d477ffbced1e.tar.bz2
gentoo-ddbfba3594bda0b32f359e057555d477ffbced1e.zip
sci-biology/bowtie: version bump, SLOT major version
sci-biology/bowtie is now SLOTed, in order to allow for a parallel installation with bowtie2. In addition, the latest bowtie now supports dev-cpp/tbb with 'tbb' USE flag.
Diffstat (limited to 'sci-biology/bowtie/files')
-rw-r--r--sci-biology/bowtie/files/bowtie-0.12.8-gcc-47.patch45
-rw-r--r--sci-biology/bowtie/files/bowtie-1.1.2-tbb-tinythread-missing.patch14
2 files changed, 14 insertions, 45 deletions
diff --git a/sci-biology/bowtie/files/bowtie-0.12.8-gcc-47.patch b/sci-biology/bowtie/files/bowtie-0.12.8-gcc-47.patch
deleted file mode 100644
index 3c8a1e1d9ca4..000000000000
--- a/sci-biology/bowtie/files/bowtie-0.12.8-gcc-47.patch
+++ /dev/null
@@ -1,45 +0,0 @@
- alphabet.h | 24 ++++++++++++------------
- 1 files changed, 12 insertions(+), 12 deletions(-)
-
-diff --git a/alphabet.h b/alphabet.h
-index b464ddf..08d0281 100644
---- a/alphabet.h
-+++ b/alphabet.h
-@@ -38,6 +38,18 @@ static inline TStr reverseComplement(const TStr& s, bool color) {
- return s_rc;
- }
-
-+/// Reverse a string in-place
-+template <typename TStr>
-+static inline void reverseInPlace(TStr& s) {
-+ typedef typename Value<TStr>::Type TVal;
-+ size_t len = length(s);
-+ for(size_t i = 0; i < (len>>1); i++) {
-+ TVal tmp = s[i];
-+ s[i] = s[len-i-1];
-+ s[len-i-1] = tmp;
-+ }
-+}
-+
- /**
- * Reverse-complement s in-place. Ns go to Ns.
- */
-@@ -69,18 +81,6 @@ static inline void reverseComplementInPlace(TStr& s, bool color) {
- }
- }
-
--/// Reverse a string in-place
--template <typename TStr>
--static inline void reverseInPlace(TStr& s) {
-- typedef typename Value<TStr>::Type TVal;
-- size_t len = length(s);
-- for(size_t i = 0; i < (len>>1); i++) {
-- TVal tmp = s[i];
-- s[i] = s[len-i-1];
-- s[len-i-1] = tmp;
-- }
--}
--
- /**
- * Return the reverse-complement of s.
- */
diff --git a/sci-biology/bowtie/files/bowtie-1.1.2-tbb-tinythread-missing.patch b/sci-biology/bowtie/files/bowtie-1.1.2-tbb-tinythread-missing.patch
new file mode 100644
index 000000000000..2a081ff297b8
--- /dev/null
+++ b/sci-biology/bowtie/files/bowtie-1.1.2-tbb-tinythread-missing.patch
@@ -0,0 +1,14 @@
+--- bowtie-1.1.2/Makefile
++++ bowtie-1.1.2/Makefile
+@@ -106,10 +106,7 @@
+ endif
+
+ OTHER_CPPS = ccnt_lut.cpp ref_read.cpp alphabet.cpp shmem.cpp \
+- edit.cpp ebwt.cpp
+-ifneq (1,$(WITH_TBB))
+- OTHER_CPPS += tinythread.cpp
+-endif
++ edit.cpp ebwt.cpp tinythread.cpp
+
+ SEARCH_CPPS = qual.cpp pat.cpp ebwt_search_util.cpp ref_aligner.cpp \
+ log.cpp hit_set.cpp refmap.cpp annot.cpp sam.cpp \