summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/clustalw
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/clustalw')
-rw-r--r--sci-biology/clustalw/Manifest2
-rw-r--r--sci-biology/clustalw/clustalw-1.83-r3.ebuild36
-rw-r--r--sci-biology/clustalw/clustalw-2.1.ebuild14
-rw-r--r--sci-biology/clustalw/files/1.83-as-needed.patch17
-rw-r--r--sci-biology/clustalw/metadata.xml5
5 files changed, 74 insertions, 0 deletions
diff --git a/sci-biology/clustalw/Manifest b/sci-biology/clustalw/Manifest
new file mode 100644
index 000000000000..7d1b7dca8a7f
--- /dev/null
+++ b/sci-biology/clustalw/Manifest
@@ -0,0 +1,2 @@
+DIST clustalw-2.1.tar.gz 350761 SHA256 e052059b87abfd8c9e695c280bfba86a65899138c82abccd5b00478a80f49486 SHA512 659cfe0121015dd2b84578b1a0a7f016fc944de155686b9bdef31122200a21e792203f3a6ab93a31676a50ffb70858b506ceb7ac27d921189a8381dbe0887921 WHIRLPOOL 93158f400cbdf11ecddcac15b5b4cee9af61d9b933f7100ad18d01d346de54c6bad5a9a12fe5a70a265c92581d3ee9cfbc41b17ee2c2ff80ff2a6658efba5f40
+DIST clustalw1.83.UNIX.tar.gz 166863 SHA256 8b757e02ae95ac0a0dd37db640497aa90f7a13a11784ce2a17f41b64e3059c60 SHA512 c0cc9ebf4c8869be819065546b499b547990342c87425fae8f921a141704343f2a518ecfc2b8bfd527061902825fc5befcb2cd080c83ba887390e48338c9dc1a WHIRLPOOL 5a075579737d8a9ba5f62d6f90feb53a275bd31a8131d1b7d21395cf46cfefbdf4e48563b55734c995b9e3d8f9c37c78ea77f4e48920d64781190645ea36112b
diff --git a/sci-biology/clustalw/clustalw-1.83-r3.ebuild b/sci-biology/clustalw/clustalw-1.83-r3.ebuild
new file mode 100644
index 000000000000..6047a08ed466
--- /dev/null
+++ b/sci-biology/clustalw/clustalw-1.83-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="General purpose multiple alignment program for DNA and proteins"
+HOMEPAGE="http://www.embl-heidelberg.de/~seqanal/"
+SRC_URI="ftp://ftp.ebi.ac.uk/pub/software/unix/clustalw/${PN}${PV}.UNIX.tar.gz"
+
+LICENSE="clustalw"
+SLOT="1"
+KEYWORDS="alpha amd64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE=""
+
+S="${WORKDIR}"/${PN}${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-as-needed.patch
+
+ sed \
+ -e "/^CC/s:cc:$(tc-getCC):g" \
+ -i makefile || die
+ sed \
+ -e "s%clustalw_help%/usr/share/doc/${PF}/clustalw_help%" \
+ -i clustalw.c || die
+}
+
+src_install() {
+ dobin clustalw
+ dodoc README clustalv.doc clustalw.doc clustalw.ms
+ insinto /usr/share/doc/${PF}
+ doins clustalw_help
+}
diff --git a/sci-biology/clustalw/clustalw-2.1.ebuild b/sci-biology/clustalw/clustalw-2.1.ebuild
new file mode 100644
index 000000000000..8664ee3108ec
--- /dev/null
+++ b/sci-biology/clustalw/clustalw-2.1.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="General purpose multiple alignment program for DNA and proteins"
+HOMEPAGE="http://www.clustal.org/"
+SRC_URI="http://www.clustal.org/download/current/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="2"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE=""
diff --git a/sci-biology/clustalw/files/1.83-as-needed.patch b/sci-biology/clustalw/files/1.83-as-needed.patch
new file mode 100644
index 000000000000..62b4654cddea
--- /dev/null
+++ b/sci-biology/clustalw/files/1.83-as-needed.patch
@@ -0,0 +1,17 @@
+--- makefile 2003-01-29 09:53:45.000000000 +0100
++++ makefile.new 2009-08-17 08:33:16.000000000 +0200
+@@ -11,11 +11,11 @@
+ HEADERS = general.h clustalw.h
+
+ CC = cc
+-CFLAGS = -c -O
+-LFLAGS = -O -lm
++CFLAGS += -c
++LIBS = -lm
+
+ clustalw : $(OBJECTS) amenu.o clustalw.o
+- $(CC) -o $@ $(OBJECTS) amenu.o clustalw.o $(LFLAGS)
++ $(CC) $(LDFLAGS) -o $@ $(OBJECTS) amenu.o clustalw.o $(LIBS)
+
+ interface.o : interface.c $(HEADERS) param.h
+ $(CC) $(CFLAGS) $*.c
diff --git a/sci-biology/clustalw/metadata.xml b/sci-biology/clustalw/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/clustalw/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>