summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-03-08 19:46:35 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-08 19:47:18 +0100
commitc7f45dbb5043e60a8b4c0a091fcb0465ffbbef50 (patch)
tree102a8bb126de462d35395ae6a2f1537c0f756954 /sci-biology/elph/elph-1.0.1-r1.ebuild
parentsci-biology/biosql: Modernise to EAPI 6 (diff)
downloadgentoo-c7f45dbb5043e60a8b4c0a091fcb0465ffbbef50.tar.gz
gentoo-c7f45dbb5043e60a8b4c0a091fcb0465ffbbef50.tar.bz2
gentoo-c7f45dbb5043e60a8b4c0a091fcb0465ffbbef50.zip
sci-biology/elph: Modernise to EAPI 6
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'sci-biology/elph/elph-1.0.1-r1.ebuild')
-rw-r--r--sci-biology/elph/elph-1.0.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-biology/elph/elph-1.0.1-r1.ebuild b/sci-biology/elph/elph-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..c166dd93e41d
--- /dev/null
+++ b/sci-biology/elph/elph-1.0.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Estimated Locations of Pattern Hits - Motif finder program"
+LICENSE="Artistic"
+HOMEPAGE="http://cbcb.umd.edu/software/ELPH/"
+SRC_URI="ftp://ftp.cbcb.umd.edu/pub/software/elph/ELPH-${PV}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+S=${WORKDIR}/${PN^^}/sources
+
+PATCHES=( "${FILESDIR}/${PN}-1.0.1-fix-build-system.patch" )
+
+src_configure() {
+ tc-export CC CXX
+}
+
+src_install() {
+ dobin elph
+
+ cd "${WORKDIR}"/ELPH || die
+ dodoc VERSION
+ newdoc Readme.ELPH README
+}