summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/picard/picard-1.103.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/picard/picard-1.103.ebuild')
-rw-r--r--sci-biology/picard/picard-1.103.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/sci-biology/picard/picard-1.103.ebuild b/sci-biology/picard/picard-1.103.ebuild
new file mode 100644
index 000000000000..16e71f41f2b0
--- /dev/null
+++ b/sci-biology/picard/picard-1.103.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+WANT_ANT_TASKS="ant-apache-bcel dev-java/testng:0 ant-junit4"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java-based command-line utilities that manipulate SAM files"
+HOMEPAGE="http://picard.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~ercpe/distfiles/${CATEGORY}/${PN}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-java/snappy:1.0
+ dev-java/cofoja:0
+ dev-java/commons-jexl:2
+ dev-java/ant-core:0"
+
+DEPEND=">=virtual/jdk-1.6
+ dev-java/ant-apache-bcel:0
+ test? (
+ dev-java/testng:0
+ dev-lang/R
+ )
+ ${CDEPEND}"
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+EANT_BUILD_TARGET="all"
+EANT_TEST_TARGET="test"
+EANT_NEEDS_TOOLS="true"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="snappy-1.0,cofoja,commons-jexl-2,ant-core"
+EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},testng"
+
+java_prepare() {
+ mkdir "${S}"/lib || die
+
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+
+ mv "${S}"/src/java/net/sf/samtools/SAMTestUtil.java "${S}"/src/tests/java/net/sf/samtools || die
+}
+
+src_install() {
+ cd dist || die
+
+ for i in *-${PV}.jar; do
+ java-pkg_newjar $i ${i/-${PV}/}
+ rm $i || die
+ done
+
+ java-pkg_dojar *.jar
+ for i in *.jar; do
+ java-pkg_dolauncher ${i/.jar/} --jar $i;
+ done
+
+ use source && java-pkg_dosrc "${S}"/src/java/*
+ use doc && java-pkg_dojavadoc "${S}"/javadoc
+}
+
+src_test() {
+ java-pkg-2_src_test
+}