summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-10-27 22:40:10 +0100
committerDavid Seifert <soap@gentoo.org>2020-10-27 22:40:10 +0100
commit0a8ba900d4d39a8f4d762fd9c04e470e3272b1d4 (patch)
treea97a6722f7b46d30c7fef94f3a5155d3f095cab5 /sci-biology/profphd
parentsci-biology/profphd: Remove old 1.0.39 (diff)
downloadgentoo-0a8ba900d4d39a8f4d762fd9c04e470e3272b1d4.tar.gz
gentoo-0a8ba900d4d39a8f4d762fd9c04e470e3272b1d4.tar.bz2
gentoo-0a8ba900d4d39a8f4d762fd9c04e470e3272b1d4.zip
sci-biology/profphd: Port to EAPI 7
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology/profphd')
-rw-r--r--sci-biology/profphd/files/profphd-1.0.40-symlink.patch11
-rw-r--r--sci-biology/profphd/profphd-1.0.40.ebuild30
2 files changed, 24 insertions, 17 deletions
diff --git a/sci-biology/profphd/files/profphd-1.0.40-symlink.patch b/sci-biology/profphd/files/profphd-1.0.40-symlink.patch
new file mode 100644
index 000000000000..7733d55af4a6
--- /dev/null
+++ b/sci-biology/profphd/files/profphd-1.0.40-symlink.patch
@@ -0,0 +1,11 @@
+--- a/src/prof/Makefile
++++ b/src/prof/Makefile
+@@ -40,7 +40,7 @@
+ ./. $(DESTDIR)$(prefix)/share/profphd/prof/.
+ find $(DESTDIR)$(prefix)/share/profphd/prof/embl/phd.pl $(DESTDIR)$(prefix)/share/profphd/prof/scr/CONFprof.pl $(DESTDIR)$(prefix)/share/profphd/prof/prof $(DESTDIR)$(prefix)/share/profphd/prof/scr/lib/prof.pm \
+ -type f -exec sed -i -e 's|__PREFIX__|$(prefix)|g;s|__VERSION__|$(VERSION)|;' {} \;
+- rm -rf $(DESTDIR)$(prefix)/bin/prof && mkdir -p $(DESTDIR)$(prefix)/bin && ln -s ../share/profphd/prof/prof $(DESTDIR)$(prefix)/bin/prof
++ rm -rf $(DESTDIR)$(prefix)/bin/prof && mkdir -p $(DESTDIR)$(prefix)/bin && ln -s ../share/profphd/prof/prof $(DESTDIR)$(prefix)/bin/profphd
+
+ install-neuralnet:
+ mkdir -p $(DESTDIR)$(prefix)/share/profphd/prof/embl/para && rsync -aC \
diff --git a/sci-biology/profphd/profphd-1.0.40.ebuild b/sci-biology/profphd/profphd-1.0.40.ebuild
index 8e24cebeb5f3..4f9a16a9fe9d 100644
--- a/sci-biology/profphd/profphd-1.0.40.ebuild
+++ b/sci-biology/profphd/profphd-1.0.40.ebuild
@@ -1,37 +1,33 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit eutils
+EAPI=7
DESCRIPTION="Secondary structure and solvent accessibility predictor"
HOMEPAGE="https://rostlab.org/owiki/index.php/PROFphd_-_Secondary_Structure,_Solvent_Accessibility_and_Transmembrane_Helices_Prediction"
SRC_URI="ftp://rostlab.org/profphd/${P}.tar.xz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
DEPEND="dev-lang/perl"
-RDEPEND="${DEPEND}
+RDEPEND="
+ ${DEPEND}
dev-perl/librg-utils-perl
sci-libs/profnet
- sci-libs/profphd-utils
-"
+ sci-libs/profphd-utils"
-src_prepare() {
- sed \
- -e '/ln -s/s:prof$:profphd:g' \
- -i src/prof/Makefile || die
- epatch "${FILESDIR}"/${PN}-1.0.39-perl.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.39-perl.patch
+ "${FILESDIR}"/${PN}-1.0.40-symlink.patch
+)
src_compile() {
- emake prefix="${EPREFIX}/usr"
+ emake prefix="${EPREFIX}"/usr
}
src_install() {
- emake prefix="${EPREFIX}/usr" DESTDIR="${D}" install
+ emake prefix="${EPREFIX}"/usr DESTDIR="${D}" install
+ einstalldocs
}