summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-25 15:53:50 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-25 16:02:16 +0100
commit8bec0995e31b2434b961c806eb5f364a52182035 (patch)
treebc0bd43f5788b1f814f430f92878f87693777851 /sci-biology/prosite/prosite-2017.02.ebuild
parentmedia-tv/kodi: version bump to 17.1_rc1. (diff)
downloadgentoo-8bec0995e31b2434b961c806eb5f364a52182035.tar.gz
gentoo-8bec0995e31b2434b961c806eb5f364a52182035.tar.bz2
gentoo-8bec0995e31b2434b961c806eb5f364a52182035.zip
sci-biology/prosite: Version bump to 2017.02
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-biology/prosite/prosite-2017.02.ebuild')
-rw-r--r--sci-biology/prosite/prosite-2017.02.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-biology/prosite/prosite-2017.02.ebuild b/sci-biology/prosite/prosite-2017.02.ebuild
new file mode 100644
index 000000000000..d2a5afa51a00
--- /dev/null
+++ b/sci-biology/prosite/prosite-2017.02.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A protein families and domains database"
+HOMEPAGE="http://prosite.expasy.org/"
+SRC_URI="ftp://ftp.expasy.org/databases/prosite/old_releases/prosite${PV//./_}.tar.bz2"
+
+LICENSE="swiss-prot"
+SLOT="0"
+# Minimal build keeps only the indexed files (if applicable).
+# The non-indexed database is not installed.
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="emboss minimal"
+
+DEPEND="emboss? ( sci-biology/emboss )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}
+
+src_compile() {
+ if use emboss; then
+ mkdir PROSITE || die
+ einfo
+ einfo "Indexing PROSITE for usage with EMBOSS"
+ EMBOSS_DATA="." prosextract -auto -prositedir "${S}" || die "Indexing PROSITE failed"
+ einfo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins *.{doc,dat}
+ fi
+
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/PROSITE
+ doins -r PROSITE/.
+ fi
+}