summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-09-10 20:00:00 +0000
committerJustin Lecher <jlec@gentoo.org>2016-09-10 20:00:37 +0000
commit45dd5298fbd9562c37729295b104ae6e4e87cc81 (patch)
tree3b36ba5dc6fde9f505586275b35a79189f427029 /sci-biology/rebase/rebase-1609.ebuild
parentdev-libs/libmateweather: remove unused patch (diff)
downloadgentoo-45dd5298fbd9562c37729295b104ae6e4e87cc81.tar.gz
gentoo-45dd5298fbd9562c37729295b104ae6e4e87cc81.tar.bz2
gentoo-45dd5298fbd9562c37729295b104ae6e4e87cc81.zip
sci-biology/rebase: Version Bump
Package-Manager: portage-2.3.0 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-biology/rebase/rebase-1609.ebuild')
-rw-r--r--sci-biology/rebase/rebase-1609.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sci-biology/rebase/rebase-1609.ebuild b/sci-biology/rebase/rebase-1609.ebuild
new file mode 100644
index 000000000000..47f2e4366830
--- /dev/null
+++ b/sci-biology/rebase/rebase-1609.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PV=${PV#1}
+
+DESCRIPTION="A restriction enzyme database"
+HOMEPAGE="http://rebase.neb.com"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="emboss minimal"
+
+RDEPEND="emboss? ( >=sci-biology/emboss-5.0.0 )"
+DEPEND="${RDEPEND}"
+
+RESTRICT="binchecks strip"
+
+src_compile() {
+ if use emboss; then
+ echo; einfo "Indexing Rebase for usage with EMBOSS."
+ mkdir REBASE || die
+ EMBOSS_DATA="." rebaseextract -auto -infile withrefm.${MY_PV} \
+ -protofile proto.${MY_PV} -equivalences \
+ || die "Indexing Rebase failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins withrefm.${MY_PV} proto.${MY_PV}
+ fi
+ newdoc REBASE.DOC README
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/REBASE
+ doins REBASE/embossre.{enz,ref,sup}
+ insinto /usr/share/EMBOSS/data
+ doins REBASE/embossre.equ
+ fi
+}