summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-01-02 11:01:11 +0000
committerJustin Lecher <jlec@gentoo.org>2017-01-02 11:02:34 +0000
commit76a382082cec100c21daf2d0bd6c4a39878a76dc (patch)
treeeaa6b611782b048e0d5d180b699927440b6be54e /sci-biology/rebase/rebase-1701.ebuild
parentsci-libs/coot-data: Update HOMEPAGE & Bump EAPI (diff)
downloadgentoo-76a382082cec100c21daf2d0bd6c4a39878a76dc.tar.gz
gentoo-76a382082cec100c21daf2d0bd6c4a39878a76dc.tar.bz2
gentoo-76a382082cec100c21daf2d0bd6c4a39878a76dc.zip
sci-biology/rebase: Version Bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-biology/rebase/rebase-1701.ebuild')
-rw-r--r--sci-biology/rebase/rebase-1701.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sci-biology/rebase/rebase-1701.ebuild b/sci-biology/rebase/rebase-1701.ebuild
new file mode 100644
index 000000000000..bc634babe48e
--- /dev/null
+++ b/sci-biology/rebase/rebase-1701.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PV=${PV#1}
+
+DESCRIPTION="A restriction enzyme database"
+HOMEPAGE="http://rebase.neb.com"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="emboss minimal"
+
+RDEPEND="emboss? ( >=sci-biology/emboss-5.0.0 )"
+DEPEND="${RDEPEND}"
+
+RESTRICT="binchecks strip"
+
+src_compile() {
+ if use emboss; then
+ echo; einfo "Indexing Rebase for usage with EMBOSS."
+ mkdir REBASE || die
+ EMBOSS_DATA="." rebaseextract -auto -infile withrefm.${MY_PV} \
+ -protofile proto.${MY_PV} -equivalences \
+ || die "Indexing Rebase failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins withrefm.${MY_PV} proto.${MY_PV}
+ fi
+ newdoc REBASE.DOC README
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/REBASE
+ doins REBASE/embossre.{enz,ref,sup}
+ insinto /usr/share/EMBOSS/data
+ doins REBASE/embossre.equ
+ fi
+}