summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/vcftools/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/vcftools/files')
-rw-r--r--sci-biology/vcftools/files/vcftools-0.1.12b-buildsystem.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/sci-biology/vcftools/files/vcftools-0.1.12b-buildsystem.patch b/sci-biology/vcftools/files/vcftools-0.1.12b-buildsystem.patch
new file mode 100644
index 000000000000..85197664a0d1
--- /dev/null
+++ b/sci-biology/vcftools/files/vcftools-0.1.12b-buildsystem.patch
@@ -0,0 +1,53 @@
+diff -ur vcftools_0.1.12b.orig/cpp/Makefile vcftools_0.1.12b/cpp/Makefile
+--- vcftools_0.1.12b.orig/cpp/Makefile 2014-08-01 21:11:22.000000000 +0200
++++ vcftools_0.1.12b/cpp/Makefile 2015-04-03 17:24:38.830781049 +0200
+@@ -3,8 +3,8 @@
+ # ($Revision: 1.1 $)
+
+ # Compiler
+-CC = gcc
+-CPP = g++
++CC ?= gcc
++CPP ?= g++
+ # Output executable
+ EXECUTABLE = vcftools
+ # Flag used to turn on compilation of PCA routines
+@@ -12,9 +12,9 @@
+ VCFTOOLS_PCA = 0
+ endif
+ # Compiler flags
+-CFLAGS = -O2 -m64
++CFLAGS ?= -O2 -m64
+ #CFLAGS = -Wall -O2 -pg -m64
+-CPPFLAGS = -O2 -D_FILE_OFFSET_BITS=64
++CPPFLAGS ?= -O2 -D_FILE_OFFSET_BITS=64
+ #CPPFLAGS = -O2 -Wall -pg -D_FILE_OFFSET_BITS=64
+ # Included libraries (zlib)
+ LIB = -lz
+@@ -29,13 +29,13 @@
+ # Define flag for PCA routine compilation
+ CPPFLAGS += -DVCFTOOLS_PCA
+ # Add LAPACK library
+- LIB += -llapack
++ LIB += `$(PKG_CONFIG) --libs lapack`
+ # Add PCA source code
+ OBJS+= dgeev.o
+ endif
+
+ vcftools: $(OBJS)
+- $(CPP) $(CPPFLAGS) $(OBJS) -o vcftools $(LIB)
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) $(OBJS) -o vcftools $(LIB)
+ ifdef BINDIR
+ cp $(CURDIR)/$@ $(BINDIR)/$@
+ endif
+@@ -47,8 +47,8 @@
+ -include $(OBJS:.o=.d)
+
+ %.o: %.cpp
+- $(CPP) -c $(CPPFLAGS) $*.cpp -o $*.o
+- $(CPP) -MM $(CPPFLAGS) $*.cpp > $*.d
++ $(CXX) -c $(CXXFLAGS) $(CPPFLAGS) $*.cpp -o $*.o
++ $(CXX) -MM $(CXXFLAGS) $(CPPFLAGS) $*.cpp > $*.d
+
+ # remove compilation products
+ clean: