summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-25 11:24:17 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-25 11:39:01 +0200
commitbdf7251db30941f3912dd646d37fb125fbabf018 (patch)
treeb3e9888c3084c07f8dae49138903d10a53f4f546 /sci-biology/vcftools/files
parentapp-arch/snappy: x86 stable wrt bug #595026 (diff)
downloadgentoo-bdf7251db30941f3912dd646d37fb125fbabf018.tar.gz
gentoo-bdf7251db30941f3912dd646d37fb125fbabf018.tar.bz2
gentoo-bdf7251db30941f3912dd646d37fb125fbabf018.zip
sci-biology/vcftools: Version bump to 0.1.14
Gentoo-bug: 594924 * EAPI=6 * Properly RDEPEND on dev-lang/perl Package-Manager: portage-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/2407 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology/vcftools/files')
-rw-r--r--sci-biology/vcftools/files/vcftools-0.1.14-buildsystem.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-biology/vcftools/files/vcftools-0.1.14-buildsystem.patch b/sci-biology/vcftools/files/vcftools-0.1.14-buildsystem.patch
new file mode 100644
index 000000000000..126a709385db
--- /dev/null
+++ b/sci-biology/vcftools/files/vcftools-0.1.14-buildsystem.patch
@@ -0,0 +1,50 @@
+* Add prefix in Makefiles, not the configure script
+* Use AC_SEARCH_LIBS instead of AC_CHECK_LIB,
+ as it is more flexible and helps us with LAPACK
+* Use correct ZLIB_CFLAGS instead of non-existent ZLIB_CPPFLAGS
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -34,7 +34,7 @@
+ [--with-pmdir=DIR],
+ [install Perl modules in DIR]),
+ [PMDIR=${withval}],
+- [PMDIR='${prefix}'/"$pmdir_relative_path"])
++ [PMDIR="$pmdir_relative_path"])
+
+ AC_SUBST([PMDIR])
+
+@@ -73,9 +73,9 @@
+ [pca=${enableval}],
+ [pca=no])
+
+-if test "x${pca}" = "xyes" ; then
+- AC_CHECK_LIB(lapack, dgeev_)
+-fi
++AS_IF([test "x${pca}" = "xyes"],[
++ AC_SEARCH_LIBS([dgeev_], [lapack])
++])
+
+ # Generate output.
+ AC_CONFIG_FILES([Makefile
+--- a/src/cpp/Makefile.am
++++ b/src/cpp/Makefile.am
+@@ -1,6 +1,6 @@
+ bin_PROGRAMS = vcftools
+
+-vcftools_CPPFLAGS = $(ZLIB_CPPFLAGS)
++vcftools_CPPFLAGS = $(ZLIB_CFLAGS)
+ vcftools_LDADD = $(ZLIB_LIBS)
+
+ vcftools_SOURCES = \
+--- a/src/perl/Makefile.am
++++ b/src/perl/Makefile.am
+@@ -24,7 +24,7 @@
+ vcf-tstv \
+ vcf-validator
+
+-pmdir = $(PMDIR)
++pmdir = $(exec_prefix)/$(PMDIR)
+
+ dist_pm_DATA = \
+ FaSlice.pm \