summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/vienna-rna/vienna-rna-2.1.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/vienna-rna/vienna-rna-2.1.1.ebuild')
-rw-r--r--sci-biology/vienna-rna/vienna-rna-2.1.1.ebuild113
1 files changed, 113 insertions, 0 deletions
diff --git a/sci-biology/vienna-rna/vienna-rna-2.1.1.ebuild b/sci-biology/vienna-rna/vienna-rna-2.1.1.ebuild
new file mode 100644
index 000000000000..df5c8eb50f90
--- /dev/null
+++ b/sci-biology/vienna-rna/vienna-rna-2.1.1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=true
+AUTOTOOLS_AUTORECONF=true
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils distutils-r1 multilib perl-module toolchain-funcs
+
+DESCRIPTION="RNA secondary structure prediction and comparison"
+HOMEPAGE="http://www.tbi.univie.ac.at/~ivo/RNA/"
+SRC_URI="http://www.tbi.univie.ac.at/~ronny/RNA/ViennaRNA-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="vienna-rna"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc openmp python static-libs"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ dev-lang/perl
+ media-libs/gd
+ doc? ( dev-texlive/texlive-latex )
+ python? (
+ ${PYTHON_DEPS}
+ dev-lang/swig )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/ViennaRNA-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-bindir.patch
+ "${FILESDIR}"/${P}-prll.patch
+ "${FILESDIR}"/${P}-impl-decl.patch
+)
+
+src_prepare() {
+ sed -i 's/ getline/ v_getline/' Readseq/ureadseq.c || die
+ sed -i 's/@PerlCmd@ Makefile.PL/& INSTALLDIRS=vendor/' Perl/Makefile.am || die
+
+ autotools-utils_src_prepare
+
+ if use python; then
+ cp "${FILESDIR}"/${P}-setup.py "${S}"/setup.py || die
+ PATCHES=()
+ distutils-r1_src_prepare
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-cluster
+ $(use_enable openmp) )
+
+ use doc || \
+ myeconfargs+=(
+ --without-doc-pdf
+ --without-doc-html
+ --without-doc
+ )
+ autotools-utils_src_configure
+ sed \
+ -e "s:LIBDIR = /usr/lib:LIBDIR = ${D}/usr/$(get_libdir):" \
+ -e "s:INCDIR = /usr/include:INCDIR = ${D}/usr/include:" \
+ -i RNAforester/g2-0.70/Makefile || die
+ sed \
+ -e "s:CC=gcc:CC=$(tc-getCC):" \
+ -e "s:^CFLAGS=:CFLAGS=${CFLAGS}:" \
+ -i Readseq/Makefile || die
+ use python && distutils-r1_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ autotools-utils_src_compile -C Readseq build CC=$(tc-getCC)
+
+ # TODO: Add (optional?) support for the NCBI toolkit.
+ if use python; then
+ pushd Perl > /dev/null
+ mv RNA_wrap.c{,-perl} || die
+ swig -python RNA.i || die
+ popd > /dev/null
+ distutils-r1_src_compile
+ mv Perl/RNA_wrap.c{-perl,} || die
+ fi
+}
+
+src_test() {
+ autotools-utils_src_compile -C Perl check
+ autotools-utils_src_compile -C Readseq test
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if ! use static-libs; then
+ rm -f "${ED}"/usr/$(get_libdir)/*.a || die
+ fi
+
+ newbin Readseq/readseq readseq-vienna
+ dodoc Readseq/Readseq.help
+ newdoc Readseq/Readme README.readseq
+ newdoc Readseq/Formats Formats.readseq
+
+ # remove perlocal.pod to avoid file collisions (see #240358)
+ perl_delete_localpod || die "Failed to remove perlocal.pod"
+ use python && distutils-r1_src_install
+}