summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/wgs-assembler/wgs-assembler-7.0-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/wgs-assembler/wgs-assembler-7.0-r1.ebuild')
-rw-r--r--sci-biology/wgs-assembler/wgs-assembler-7.0-r1.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/sci-biology/wgs-assembler/wgs-assembler-7.0-r1.ebuild b/sci-biology/wgs-assembler/wgs-assembler-7.0-r1.ebuild
new file mode 100644
index 000000000000..b3ac7c30813b
--- /dev/null
+++ b/sci-biology/wgs-assembler/wgs-assembler-7.0-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND=2
+
+inherit eutils python toolchain-funcs
+
+DESCRIPTION="A de novo whole-genome shotgun DNA sequence assembler, also known as the Celera Assembler and CABOG"
+HOMEPAGE="http://sourceforge.net/projects/wgs-assembler/"
+SRC_URI="mirror://sourceforge/${PN}/wgs-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs"
+
+DEPEND="
+ x11-libs/libXt
+ !x11-terms/terminator"
+RDEPEND="${DEPEND}
+ app-shells/tcsh
+ dev-perl/Log-Log4perl"
+
+S="${WORKDIR}/wgs-${PV}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-build.patch
+ tc-export CC CXX
+}
+
+src_configure() {
+ cd "${S}/kmer"
+ ./configure.sh || die
+}
+
+src_compile() {
+ # not really an install target
+ emake -C kmer -j1 install
+ emake -C src -j1 SITE_NAME=LOCAL
+}
+
+src_install() {
+ OSTYPE=$(uname)
+ MACHTYPE=$(uname -m)
+ MACHTYPE=${MACHTYPE/x86_64/amd64}
+ MY_S="${OSTYPE}-${MACHTYPE}"
+ sed -i 's|#!/usr/local/bin/|#!/usr/bin/env |' $(find $MY_S -type f) || die
+
+ sed -i '/sub getBinDirectory ()/ a return "/usr/bin";' ${MY_S}/bin/runCA* || die
+ sed -i '/sub getBinDirectoryShellCode ()/ a return "bin=/usr/bin\n";' ${MY_S}/bin/runCA* || die
+ sed -i '1 a use lib "/usr/share/'${PN}'/lib";' $(find $MY_S -name '*.p*') || die
+
+ dobin kmer/${MY_S}/bin/*
+ insinto /usr/$(get_libdir)/${PN}
+ use static-libs && doins kmer/${MY_S}/lib/*
+
+ insinto /usr/include/${PN}
+ doins kmer/${MY_S}/include/*
+
+ insinto /usr/share/${PN}/lib
+ doins -r ${MY_S}/bin/TIGR
+ rm -rf ${MY_S}/bin/TIGR || die
+ dobin ${MY_S}/bin/*
+ use static-libs && dolib.a ${MY_S}/lib/*
+ dodoc README
+}