summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-04-05 16:14:44 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-05 16:14:44 +0200
commit911367bccf61ee5e03acb127c6076eb6f0a5e80c (patch)
tree1ce490b7516fbd4bda04598ea948c4bc65ed825e /sci-biology
parentsci-biology/mothur: Port to EAPI 7 (diff)
downloadgentoo-911367bccf61ee5e03acb127c6076eb6f0a5e80c.tar.gz
gentoo-911367bccf61ee5e03acb127c6076eb6f0a5e80c.tar.bz2
gentoo-911367bccf61ee5e03acb127c6076eb6f0a5e80c.zip
sci-biology/probcons: Port to EAPI 7
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/probcons/probcons-1.12-r1.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/sci-biology/probcons/probcons-1.12-r1.ebuild b/sci-biology/probcons/probcons-1.12-r1.ebuild
index 01973b88cab9..15960982abff 100644
--- a/sci-biology/probcons/probcons-1.12-r1.ebuild
+++ b/sci-biology/probcons/probcons-1.12-r1.ebuild
@@ -1,35 +1,31 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
MY_P="${PN}_v${PV/./_}"
DESCRIPTION="Probabilistic Consistency-based Multiple Alignment of Amino Acid Sequences"
HOMEPAGE="http://probcons.stanford.edu/"
SRC_URI="http://probcons.stanford.edu/${MY_P}.tar.gz"
+S="${WORKDIR}/${PN}"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
# Gnuplot is explicitly runtime-only, it's run using system()
RDEPEND="
!sci-geosciences/gmt
sci-visualization/gnuplot"
-DEPEND=""
-
-S="${WORKDIR}/${PN}"
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-cxxflags.patch \
- "${FILESDIR}"/gcc-4.3.patch \
- "${FILESDIR}"/${P}-gcc-4.6.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-cxxflags.patch
+ "${FILESDIR}"/gcc-4.3.patch
+ "${FILESDIR}"/${P}-gcc-4.6.patch
+)
src_compile() {
emake \