summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-24 08:29:55 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-24 08:29:55 +0100
commitad0f0da9f1b0df76d06b2bd4c52ce233ce4c8001 (patch)
treeaa42bbc587a457ae8a0cd49d5c92e3af1f2877b4 /sci-biology
parentsci-biology/biopython: add 1.81 (diff)
downloadgentoo-ad0f0da9f1b0df76d06b2bd4c52ce233ce4c8001.tar.gz
gentoo-ad0f0da9f1b0df76d06b2bd4c52ce233ce4c8001.tar.bz2
gentoo-ad0f0da9f1b0df76d06b2bd4c52ce233ce4c8001.zip
sci-biology/bowtie: add 2.5.1
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/bowtie/Manifest1
-rw-r--r--sci-biology/bowtie/bowtie-2.5.1.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/sci-biology/bowtie/Manifest b/sci-biology/bowtie/Manifest
index e62703395825..274e5e7b9fb6 100644
--- a/sci-biology/bowtie/Manifest
+++ b/sci-biology/bowtie/Manifest
@@ -1 +1,2 @@
DIST bowtie2-2.4.4-source.zip 10515984 BLAKE2B be4ceb9d3155d2a9a1f580e5032251b04b89ce0c8c9c89fc3551b34fe3bd71a683362488be7aad6daef24734c6f95c19223f20e67f198f745c4432381243039c SHA512 1b5dadd7e41b90bb9b05f50bfa171fe219cfd03aa8bb6f800de4baaffeb975eef6efc4fb8b49cb0d18833f74a1741cbe1556b87388f59188e04a55dcee6a02da
+DIST bowtie2-2.5.1-source.zip 10528859 BLAKE2B 9dc22bfef4b3a1cfaa606cb235acd1d7688015678d82e8ca80d3d7cf269e1f45d6cb60bc29eb334fb6f0c25d5afd8202e83a83e53668c8965857b8885d2692c8 SHA512 31cc642e318ab50e7ef6035a9c2095024d46d92a317011ed0c3ac3ccb3d427a13bf724d0158d29a4f1e07115ddcb85229b95bcb2d4351164fcadd6568293565f
diff --git a/sci-biology/bowtie/bowtie-2.5.1.ebuild b/sci-biology/bowtie/bowtie-2.5.1.ebuild
new file mode 100644
index 000000000000..353362fd6026
--- /dev/null
+++ b/sci-biology/bowtie/bowtie-2.5.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit python-single-r1 toolchain-funcs
+
+DESCRIPTION="Popular short read aligner for Next-generation sequencing data"
+HOMEPAGE="https://bowtie-bio.sourceforge.net/bowtie2/"
+SRC_URI="mirror://sourceforge/project/${PN}-bio/bowtie2/${PV}/bowtie2-${PV}-source.zip"
+S="${WORKDIR}/${PN}2-${PV}"
+
+LICENSE="GPL-3"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test cpu_flags_x86_sse2 examples"
+# Test script missing from tarball
+# ./scripts/sim/run.sh: No such file or directory
+RESTRICT="test"
+REQUIRED_USE="cpu_flags_x86_sse2 ${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-lang/perl
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/unzip
+ test? (
+ dev-perl/App-cpanminus
+ dev-perl/B-COW
+ dev-perl/Clone
+ dev-perl/Config-General
+ dev-perl/File-Which
+ dev-perl/local-lib
+ dev-perl/Math-Random
+ dev-perl/Test-Deep
+ dev-perl/Text-Template
+ )
+"
+
+src_compile() {
+ emake \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="" \
+ CPPFLAGS="${CPPFLAGS}" \
+ EXTRA_FLAGS="${LDFLAGS}" \
+ RELEASE_FLAGS="${CXXFLAGS} -msse2"
+}
+
+src_install() {
+ dobin bowtie2 bowtie2-*
+
+ exeinto /usr/libexec/bowtie2
+ doexe scripts/*
+
+ HTML_DOCS=( doc/{manual.html,style.css} )
+ einstalldocs
+ dodoc TUTORIAL
+ newman MANUAL bowtie2.1
+
+ python_fix_shebang "${ED}"/usr/bin/bowtie2-{build,inspect}
+
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}