summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-04-05 16:14:38 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-05 16:14:38 +0200
commitd3bc203ff48c69ad14e9b659c8d9c3c9d6d85bff (patch)
tree1ad65965ad0eeba47f8e1fa1339228d5ef34c82e /sci-biology
parentsci-biology/sibsim4: Port to EAPI 7 (diff)
downloadgentoo-d3bc203ff48c69ad14e9b659c8d9c3c9d6d85bff.tar.gz
gentoo-d3bc203ff48c69ad14e9b659c8d9c3c9d6d85bff.tar.bz2
gentoo-d3bc203ff48c69ad14e9b659c8d9c3c9d6d85bff.zip
sci-biology/raxml: Port to EAPI 7
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/raxml/files/raxml-7.2.6-makefile.patch4
-rw-r--r--sci-biology/raxml/raxml-7.2.6.ebuild25
2 files changed, 12 insertions, 17 deletions
diff --git a/sci-biology/raxml/files/raxml-7.2.6-makefile.patch b/sci-biology/raxml/files/raxml-7.2.6-makefile.patch
index ae83e2eef4e7..6b82ed65b770 100644
--- a/sci-biology/raxml/files/raxml-7.2.6-makefile.patch
+++ b/sci-biology/raxml/files/raxml-7.2.6-makefile.patch
@@ -14,7 +14,7 @@ index 716b6c6..f0c1de2 100644
-CFLAGS = -D_GNU_SOURCE -fomit-frame-pointer -funroll-loops -O2 -msse
-+CFLAGS += -D_GNU_SOURCE
++CPPFLAGS += -D_GNU_SOURCE
@@ -23,7 +23,7 @@ index 716b6c6..f0c1de2 100644
raxmlHPC : $(objs)
- $(CC) -o raxmlHPC $(objs) $(LIBRARIES)
-+ $(CC) $(LDFLAGS) -o raxmlHPC $(objs) $(LIBRARIES)
++ $(CC) $(LDFLAGS) -o raxmlHPC $(objs) $(LIBRARIES) $(LIBS)
classify.o : classify.c $(GLOBAL_DEPS)
evaluatePartialSpecialGeneric.o : evaluatePartialSpecialGeneric.c $(GLOBAL_DEPS)
diff --git a/sci-biology/raxml/raxml-7.2.6.ebuild b/sci-biology/raxml/raxml-7.2.6.ebuild
index 50fffc34accb..adb044426381 100644
--- a/sci-biology/raxml/raxml-7.2.6.ebuild
+++ b/sci-biology/raxml/raxml-7.2.6.ebuild
@@ -1,34 +1,29 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils flag-o-matic toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Sequential, Parallel & Distributed Inference of Large Phylogenetic Trees"
HOMEPAGE="http://wwwkramer.in.tum.de/exelixis/software.html"
SRC_URI="http://wwwkramer.in.tum.de/exelixis/software/RAxML-${PV}.tar.bz2"
+S="${WORKDIR}/RAxML-${PV}"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="cpu_flags_x86_sse3 +threads"
-
REQUIRED_USE="cpu_flags_x86_sse3"
# mpi is not supported in version 7.2.2. mpi is enabled by adding -DPARALLEL to CFLAGS
-DEPEND="" # mpi? ( virtual/mpi )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/RAxML-${PV}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-makefile.patch
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
- use cpu_flags_x86_sse3 && append-cflags -D__SIM_SSE3
+src_configure() {
+ use cpu_flags_x86_sse3 && append-cppflags -D__SIM_SSE3
use threads && \
- append-cflags -D_USE_PTHREADS && \
- append-ldflags -pthread
+ append-cppflags -D_USE_PTHREADS && \
+ append-libs -pthread
tc-export CC
}