summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-12-20 14:32:52 +0100
committerDavid Seifert <soap@gentoo.org>2021-12-20 14:32:52 +0100
commitde858ae7cf457b2ef508edce83f809403346ac0f (patch)
treee666887c5de5b8c07316ea526627fb8a44ef2eea /sci-biology
parentapp-office/calligra: EAPI-8, drop IUSE openexr, missing RDEPEND (diff)
downloadgentoo-de858ae7cf457b2ef508edce83f809403346ac0f.tar.gz
gentoo-de858ae7cf457b2ef508edce83f809403346ac0f.tar.bz2
gentoo-de858ae7cf457b2ef508edce83f809403346ac0f.zip
sci-biology/biopython: add 1.79
Bug: https://bugs.gentoo.org/757867 Bug: https://bugs.gentoo.org/780345 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/biopython/Manifest1
-rw-r--r--sci-biology/biopython/biopython-1.79.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/sci-biology/biopython/Manifest b/sci-biology/biopython/Manifest
index 420f6d1f83d8..9bc0eede97dc 100644
--- a/sci-biology/biopython/Manifest
+++ b/sci-biology/biopython/Manifest
@@ -1 +1,2 @@
DIST biopython-1.77.tar.gz 16837021 BLAKE2B b5586f0ea3e476b11801dcc98039d5eea7b191e11d390192c0cf348018ded005fe2ad5dc9ba71c83aebc9cdde20c97244905dcc3aeb5436a97588da9f8c79c3e SHA512 6f4b03d46c591e1f49dd1e76bcc4ac5c9aaa2bf748c9dd37ffc5de5a613fbeed38f89b418c01601dd99c65b13b2e294bc8d81ffafc42a9ff1b309c84f840d0d5
+DIST biopython-1.79.tar.gz 16738730 BLAKE2B 8c97fc23e458f7bc98b0ed0226bd6fb42f6c6f3ce03d562b13fac66c5061451595cd5bd01cad07bbe1fc6b20f4de21b0f03766b5a20e602545da888047a57185 SHA512 81e2718f4015bb038637b4d1181e6bea48018fec1e769c5f0ab75442a769336899191f1222e82e1b9569c1fac470500d7582420e5cbe9bce0056b41751adeaaa
diff --git a/sci-biology/biopython/biopython-1.79.ebuild b/sci-biology/biopython/biopython-1.79.ebuild
new file mode 100644
index 000000000000..cef9a670130a
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.79.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python modules for computational molecular biology"
+HOMEPAGE="https://www.biopython.org/ https://pypi.org/project/biopython/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/rdflib[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ >=dev-python/reportlab-3.5.13-r1[${PYTHON_USEDEP}]
+ dev-python/pydot[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/flex"
+
+DOCS=( {CONTRIB,DEPRECATED,NEWS,README}.rst Doc/. )
+
+python_test() {
+ distutils_install_for_testing
+ cp -r {Doc,Tests} "${TEST_DIR}"/lib/ || die
+
+ # need to create symlinks for doctests
+ mkdir -p "${TEST_DIR}"/lib/Bio/Align || die
+ ln -r -s "${S}"/Bio/Align/substitution_matrices \
+ "${TEST_DIR}"/lib/Bio/Align/substitution_matrices || die
+
+ cd "${TEST_DIR}"/lib/Tests || die
+ rm test_BioSQL_{psycopg2.py,MySQLdb.py,mysql_connector.py} || die
+ "${EPYTHON}" run_tests.py --offline --verbose || die
+}
+
+python_install_all() {
+ # remove files causing ecompressdir to fail
+ rm Doc/examples/ls_orchid.gbk.{gz,bz2} || die
+
+ distutils-r1_python_install_all
+
+ dodir /usr/share/${PN}
+ cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
+}
+
+pkg_postinst() {
+ optfeature_header "For database support you need to install:"
+ optfeature "MySQL database support" dev-python/mysqlclient
+ optfeature "PostgreSQL database support" dev-python/psycopg
+
+ optfeature_header "Some applications need extra packages:"
+ optfeature "EMBOSS (The European Molecular Biology Open Software Suite)" sci-biology/emboss
+}